public inbox for cygwin-xfree@sourceware.org
help / color / mirror / Atom feed
From: "Joshua J. Yi" <joshua.yi@gmail.com>
To: cygwin-xfree@cygwin.com
Subject: connection refused (errno 111): unable to connect to X server
Date: Tue, 09 Aug 2011 15:58:00 -0000	[thread overview]
Message-ID: <4E415913.7050107@gmail.com> (raw)

[-- Attachment #1: Type: text/plain, Size: 1242 bytes --]

Hi All,

I've been having this problem for a while now and I can't seem to figure 
out how to solve it. I've checked the FAQ, mailing lists, and done web 
searches, but unless I've missed something (quite possible!), the 
solution to my problem isn't out there.

When I run "startxwin" in the bash window, I get the following error:

---

giving up
startxwin:  Connection refused (errno 111):  unable to connect to X server
startxwin:  No such process (errno 3):  Server error

---

The error log (XWin.0.log) is attached.

For some reason, X doesn't start or isn't working. (Same result when I 
start from X from the start button.)

This has been an on-going problem for months now (been working on it 
intermittantly), and after multiple updates, so I don't think it's a 
package-version issue. Currently, I've installed every package in 
cygwin, but that doesn't help.

I haven't had problems installing cygwin in the past on different 
computers, so I wonder if it's a library problem (something) with this 
computer (a thinkpad).

Anyways, I'll apologize in advance if the solution is out there already, 
but after digging through the FAQ and mailing lists and trying various 
things, I'm at wit's end.

Also, thanks in advance.

-Josh


[-- Attachment #2: XWin.0.log --]
[-- Type: text/plain, Size: 2343 bytes --]

Welcome to the XWin X Server
Vendor: The Cygwin/X Project
Release: 1.10.3.0
OS: Windows XP Service Pack 3 [Windows NT 5.1 build 2600] (Win32)
Package: version 1.10.3-1 built 2011-07-19

XWin was started with the following command line:

/usr/bin/X :0 -clipboard -multiwindow -auth 
 /home/Administrator/.serverauth.3000 

ddxProcessArgument - Initializing default screens
winInitializeScreenDefaults - primary monitor w 1680 h 1050
winInitializeDefaultScreens - native DPI x 96 y 96
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/nbb:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
[432576.406] (II) xorg.conf is not supported
[432576.406] (II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more information
[432576.406] LoadPreferences: /home/Administrator/.XWinrc not found
[432576.406] LoadPreferences: Loading /etc/X11/system.XWinrc
[432576.406] LoadPreferences: Done parsing the configuration file...
[432576.406] winDetectSupportedEngines - DirectDraw installed, allowing ShadowDD
[432576.406] winDetectSupportedEngines - Windows NT, allowing PrimaryDD
[432576.406] winDetectSupportedEngines - DirectDraw4 installed, allowing ShadowDDNL
[432576.406] winDetectSupportedEngines - Returning, supported engines 0000001f
[432576.406] winTaskbarInit - Could not get SHGetPropertyStoreForWindow address
[432576.406] winSetEngine - Multi Window or Rootless => ShadowGDI
[432576.406] winScreenInit - Using Windows display depth of 32 bits per pixel
[432576.421] winAllocateFBShadowGDI - Creating DIB with width: 1680 height: 1050 depth: 32
[432576.421] winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff
[432576.421] winInitVisualsShadowGDI - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 bpp 32
[432576.421] winInitMultiWindowWM - Calling pthread_mutex_lock ()
[432576.421] winMultiWindowXMsgProc - Calling pthread_mutex_lock ()
[432576.421] Screen 0 added at virtual desktop coordinate (0,0).
[432576.421] MIT-SHM extension disabled due to lack of kernel support
[432576.437] XFree86-Bigfont extension local-client optimization disabled due to lack of shared memory support in the kernel
[432576.625] (II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so
[432576.625] (II) GLX: Initialized DRISWRAST GL provider for screen 0


[-- Attachment #3: Type: text/plain, Size: 223 bytes --]

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

                 reply	other threads:[~2011-08-09 15:58 UTC|newest]

Thread overview: [no followups] expand[flat|nested]  mbox.gz  Atom feed

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4E415913.7050107@gmail.com \
    --to=joshua.yi@gmail.com \
    --cc=cygwin-xfree@cygwin.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).