public inbox for cygwin-xfree@sourceware.org
help / color / mirror / Atom feed
* Re: Unable to open socket for inet
@ 2011-08-04 20:59 J T Halliley
  0 siblings, 0 replies; 4+ messages in thread
From: J T Halliley @ 2011-08-04 20:59 UTC (permalink / raw)
  To: cygwin-xfree

I've got Cygwin/X working now.   I had to 

1.  Shut down all cygwin processes.
2.  Run ash from a DOS window.
3.  Execute /bin/rebaseall

Now all is good.

Tom


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/


^ permalink raw reply	[flat|nested] 4+ messages in thread
* Re: Unable to open socket for inet
@ 2011-08-04 20:18 J T Halliley
  0 siblings, 0 replies; 4+ messages in thread
From: J T Halliley @ 2011-08-04 20:18 UTC (permalink / raw)
  To: cygwin-xfree

The first problem I found is that you must leave SYSTEMROOT set to 
c:\windows, not to /c/windows or /cygdrive/c/windows.  This allowed ping 
to work.

However, I'm still having X issues (but it got farther):

-------------------------------------
bash> startxwin

Welcome to the XWin X Server
Vendor: The Cygwin/X Project
Release: 1.10.3.0
OS: Windows XP Service Pack 3 [Windows NT 5.1 build 2600] (Win32)
Package: version 1.10.3-1 built 2011-07-19

XWin was started with the following command line:

X :0 -multiwindow 

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/GP3JDP1-E6410:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
(II) xorg.conf is not supported
(II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more 
information
LoadPreferences: /home/jth180/.XWinrc not found
LoadPreferences: Loading /etc/X11/system.XWinrc
LoadPreferences: Done parsing the configuration file...
winDetectSupportedEngines - DirectDraw installed, allowing ShadowDD
winDetectSupportedEngines - Windows NT, allowing PrimaryDD
winDetectSupportedEngines - DirectDraw4 installed, allowing ShadowDDNL
winDetectSupportedEngines - Returning, supported engines 0000001f
winTaskbarInit - Could not get SHGetPropertyStoreForWindow address
winSetEngine - Multi Window or Rootless => ShadowGDI
winScreenInit - Using Windows display depth of 32 bits per pixel
winAllocateFBShadowGDI - Creating DIB with width: 2880 height: 900 depth: 
32
winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff
winInitVisualsShadowGDI - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 
bpp 32
winInitMultiWindowWM - Calling pthread_mutex_lock ()
Screen 0 added at virtual desktop coordinate (0,0).
winMultiWindowXMsgProc - Calling pthread_mutex_lock ()
MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to lack 
of shared memory support in the kernel
(II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so
(II) GLX: Initialized DRISWRAST GL provider for screen 0
[dix] Could not init font path element /usr/share/fonts/TTF/, removing 
from list!
[dix] Could not init font path element /usr/share/fonts/OTF/, removing 
from list!
[dix] Could not init font path element /usr/share/fonts/Type1/, removing 
from list!
      2 [main] X 7304 fork: child -1 - died waiting for longjmp before 
initialization, retry 0, exit code 0x100, errno 11
giving up.
startxwin:  Connection refused (errno 111):  unable to connect to X server
startxwin:  No such process (errno 3):  Server error.
-------------------------------------

Ideas?




--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/


^ permalink raw reply	[flat|nested] 4+ messages in thread
* Unable to open socket for inet
@ 2011-08-03 22:35 J T Halliley
  2011-08-04  6:19 ` Marco atzeri
  0 siblings, 1 reply; 4+ messages in thread
From: J T Halliley @ 2011-08-03 22:35 UTC (permalink / raw)
  To: cygwin-xfree

Just installed Cygwin/X on WIndows XP Pro, Version 2002, SP 3.
When I invoke startxwin, here's what I get:

----------------------
bash> startxwin

Welcome to the XWin X Server
Vendor: The Cygwin/X Project
Release: 1.10.3.0
OS: Windows XP Service Pack 3 [Windows NT 5.1 build 2600] (Win32)
Package: version 1.10.3-1 built 2011-07-19

XWin was started with the following command line:

X :0 -multiwindow 

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/GP3JDP1-E6410:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet
_XSERVTransOpen: transport open failed for inet/GP3JDP1-E6410:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet
_XSERVTransSocketOpenCOTSServer: Unable to open socket for local
_XSERVTransOpen: transport open failed for local/GP3JDP1-E6410:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for local

Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't 
already running
winDeinitMultiWindowWM - Noting shutdown in progress
----------------------

It seems as though there's a general networking issue: 

----------------------
bash> ping 127.0.0.1
icmp: unknown protocol
----------------------

but using Windows ping from a DOS prompt works fine:

----------------------
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\>ping 127.0.0.1

Pinging 127.0.0.1 with 32 bytes of data:

Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128

Ping statistics for 127.0.0.1:
    Packets: Sent = 3, Received = 3, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
Control-C
^C
C:\>
----------------------

I am in the Administrators group, so raw sockets should work.  We do run 
McAfee, so that could be an issue.

Any ideas?  Both for XWin and for ping?  Are they related?

Thanks,
Tom

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2011-08-04 20:59 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-08-04 20:59 Unable to open socket for inet J T Halliley
  -- strict thread matches above, loose matches on Subject: below --
2011-08-04 20:18 J T Halliley
2011-08-03 22:35 J T Halliley
2011-08-04  6:19 ` Marco atzeri

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).