public inbox for
 help / color / mirror / Atom feed
From: "Alan W. Irwin" <>
To: Joe Cooper <>
Subject: Re: pdf output.
Date: Tue, 27 Feb 2001 14:58:00 -0000	[thread overview]
Message-ID: <Pine.LNX.4.21.0102271302390.21013-100000@localhost> (raw)
In-Reply-To: <>

Hello Joe:

All I will say about your postscript problem is I suspect an unclean upgrade
(see rpm comments below about how to insure a clean upgrade).  The rest of
this post will concentrate on your pdf problems.

First, the site which you quoted in your message gives URL not found for me.
I use .

I just visited there today and brought my rpm package files up to date
and installed all the latest versions that had changed.  Here is the
exact list of rpm package files which I currently have installed on my system.

docbook-dtd31-sgml-1.0-6.noarch.rpm    jade-1.2.1-6.i386.rpm
docbook-dtd41-sgml-1.0-6.noarch.rpm    jadetex-2.20-6.noarch.rpm
docbook-dtd41-xml-1.0-3.noarch.rpm     perl-SGMLSpm-1.03ii-3.noarch.rpm
docbook-style-dsssl-1.61-1.noarch.rpm  sgml-common-0.6.1-1.noarch.rpm

Make sure before you install all this stuff that all other docbook
stuff has been completely cleaned out.  **You cannot use a mixture of
these cygnus new-trials rpms and vanilla RedHat 6.2 rpm's.**  Furthermore,
even when you uninstall old rpm's, there may be left over files around which
could be screwing you up.  So once you uninstall everything look in the
standard docbook directories (use rpm -ql on the above packages to see
what those directories are) to make sure they are really empty.  Once
that is verified, then use rpm -i *.rpm to install all these rpm's at
once.  rpm is smart enough to figure out the dependencies if there are
multiple package files on the command line (e.g., *.rpm).

With a clean install of these rpm's I have no trouble generating pdf
documents (in one case with 180 pages) on my RH 6.2 system.

Also, IIRC, the (Fatal format file error; I'm stymied) message you get *is*
the result of lack of resources for pdf generation.  I find that the
following set of resources in the texmf.cnf file work well for me. Note the
two different suffixes on the variables for jadetex and psfjadetex

  hash_extra.jadetex  = 32500
  hash_extra.pdfjadetex  = 32500
  pool_size.jadetex = 500000
  pool_size.pdfjadetex = 500000
  string_vacancies.jadetex = 45000
  string_vacancies.pdfjadetex = 45000
  max_strings.jadetex = 58500
  max_strings.pdfjadetex = 58500
  pool_free.jadetex = 47500
  pool_free.pdfjadetex = 47500
  nest_size.jadetex = 500
  nest_size.pdfjadetex = 500
  param_size.jadetex = 1500
  param_size.pdfjadetex = 1500
  save_size.jadetex = 10000
  save_size.pdfjadetex = 10000
  stack_size.jadetex = 1500
  stack_size.pdfjadetex = 1500
  extra_mem_bot.jadetex = 85000
  extra_mem_bot.pdfjadetex = 85000

Once these values are in your texmf.cnf file, then run texhash and fmtutil
appropriately to make new jadetex and pdfjadetex executables with the new
resources.  do rpm -qp --scripts jadetex-2.20-6.noarch.rpm to see how to run
these programmes *for the special case of jadetex and pdfjadetex*.  (Of
course if you have installed jadetex after you have changed texmf.cnf, then
these programmes were executed with the right texmf.cnf, and there is
nothing more to do.)

If you follow these directions, I don't think you should have any further
trouble with pdf.  It has been working well for me for several months now
and through several minor upgrades (as I did today just to make sure nothing
bad had been introduced for my 180-page document) of the Cygnus packages.

Alan W. Irwin

phone: 250-727-2902	FAX: 250-721-7715
Dr. Alan W. Irwin
Department of Physics and Astronomy,
University of Victoria, P.O. Box 3055,
Victoria, British Columbia, Canada, V8W 3P6 

Linux-powered astrophysics

On Tue, 27 Feb 2001, Joe Cooper wrote:

> Ok...I've seen this discussed innumerable times on the list.  And a 
> search of the archives reveals lots of similar queries and problems. 
> But no presented solutions have worked for me, and I'm reaching a state 
> of mind most akin to 'banging head on wall'.
> I've tried this on both RH6.2 and RH7.  I've used the older db2pdf 
> utilities as well as the latest docbook2pdf (from 
> ).  Both will produce 
> HTML output fine.  However, both fail in different ways to produce a pdf 
> file.
> I've seen the suggestion to modify some values in the texmf.cnf 
> file...however, I found that the values in a default Red Hat install are 
> already larger than or equal to the ones suggested by Eric.  Further, 
> error logs (when they are generated in attempting PS output) indicate 
> that those limits are not being hit, or anywhere near it.
> I've tried doing the very simplest thing I could manage (Eric's 
> helloworld.docbook example) and it fails as well.
> docbook2pdf hello.docbook generates the following:
> Using catalogs: /etc/sgml/
> Using stylesheet: 
> /usr/share/sgml/docbook/utils-0.6.6/docbook-utils.dsl#print
> Working on: /home/joe/swelldocs/webmin/hello.docbook
> This is pdfTeX, Version 3.14159-13d (Web2C 7.3.1)
> (Fatal format file error; I'm stymied)
> Any suggestions?  What do I have to do to make this work?
> BTW-Postscript output worked, up to about page 78 of my 200 page doc, 
> until I upgraded to the docbook2 it fails with a heap of 
> Reference errors even on the tiny hello document, as well as 'No file 
> hello.aux.', as well as some errors in a .log file.  The errors in the 
> .log file indicate a few "Reference" errors, but the interesting bit is 
> that at the end of the log, it is very clear that TeX is not running out 
> of memory/buffers/whatever...all of the various numbers are quite a bit 
> less than the max.
> Thanks.
>                                    --
>                       Joe Cooper <>
>                   Affordable Web Caching Proxy Appliances

  reply	other threads:[~2001-02-27 14:58 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2001-02-27 10:25 Joe Cooper
2001-02-27 14:58 ` Alan W. Irwin [this message]
2001-12-19 22:49   ` Joe Cooper
2001-02-27 15:25     ` Joe Cooper

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Pine.LNX.4.21.0102271302390.21013-100000@localhost \ \ \ \

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).