public inbox for ecos-patches@sourceware.org
 help / color / mirror / Atom feed
From: bugzilla-daemon@bugs.ecos.sourceware.org
To: ecos-patches@ecos.sourceware.org
Subject: [Bug 1001142] User defined linker sections.
Date: Mon, 14 Feb 2011 13:03:00 -0000	[thread overview]
Message-ID: <20110214130309.91ABA2F78001@mail.ecoscentric.com> (raw)
In-Reply-To: <bug-1001142-104@http.bugs.ecos.sourceware.org/>

Please do not reply to this email. Use the web interface provided at:
http://bugs.ecos.sourceware.org/show_bug.cgi?id=1001142

--- Comment #11 from Ilija Kocho <ilijak@siva.com.mk> 2011-02-14 13:03:08 GMT ---
(In reply to comment #9)
> (In reply to comment #8)
> > (In reply to comment #7)
> > > (In reply to comment #6)
> [snip]
> > > > I do agree that the name "SECTION_user()" could lead to some confusion
> > > > with the existing SECTION_*() macros which have a different number of
> > > > parameters.  I would be happy to use a macro name such as
> > > > "USER_SECTION()" instead.
> > > 
> > > John, then I "found" such a name too :-), and I like this name and now I
> > > would argee with your points about macro placement (cortexm.ld).
> > 
> > Me too, do you need me to produce a new patch?
> 
> So, we are happy with USER_SECTION(). What's about those SECTION_START,
> SECTION_END definitions in the Attachment 1116 [details] ?  Will be they ever
> used then? IMO, the names are too generic and seem like the "reserved"
> words ...
> 
> If you need those defs, what is about USER_LABEL() instead?
> 
> #define USER_LABEL(_label_) \
>     ...
> 
> If we do not need those defs at all, I would be happy with (not tested)
> 
> --- a/packages/hal/cortexm/arch/current/src/cortexm.ld
> +++ b/packages/hal/cortexm/arch/current/src/cortexm.ld
> @@ -268,5 +268,11 @@ OUTPUT_FORMAT(elf32-bigarm)
> 
>  #define SECTIONS_END . = ALIGN(4); _end = .; PROVIDE (end = .);
> 
> +#define USER_SECTION(_name_, _region_, _vma_, _lma_) \
> +    . ## _name_ _vma_ : _lma_ \
> +    { __ ## _name_ ## _start = ABSOLUTE (.); \
> +    *(. ## _name_)* \
> +    __ ## _name_ ## _end = ABSOLUTE (.); }
> +
>  #include <pkgconf/hal_cortexm.h>
>  #include CYGHWR_MEMORY_LAYOUT_LDI
> 
> Comments?

I introduced them because of properties of CPP concatenation ## with respect to
argument prescan.
http://gcc.gnu.org/onlinedocs/cpp/Argument-Prescan.html#Argument-Prescan
They are needed if "_name_" is a macro:

#define FOO "foo"
USER_SECTION(FOO, reg, vma, lma)

Example use case is when the section name is provided via CDL.
I would keep them but we may consider more suitable names.

-- 
Configure bugmail: http://bugs.ecos.sourceware.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

  parent reply	other threads:[~2011-02-14 13:03 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-02-03 15:43 [Bug 1001142] New: " bugzilla-daemon
2011-02-03 17:02 ` [Bug 1001142] " bugzilla-daemon
2011-02-13 17:40 ` bugzilla-daemon
2011-02-13 18:47 ` bugzilla-daemon
2011-02-13 19:02 ` bugzilla-daemon
2011-02-13 19:50 ` bugzilla-daemon
2011-02-13 20:02 ` bugzilla-daemon
2011-02-14  7:28 ` bugzilla-daemon
2011-02-14  8:36 ` bugzilla-daemon
2011-02-14  9:17 ` bugzilla-daemon
2011-02-14 12:34 ` bugzilla-daemon
2011-02-14 12:44 ` bugzilla-daemon
2011-02-14 13:03 ` bugzilla-daemon [this message]
2011-02-14 13:16 ` bugzilla-daemon
2011-02-14 13:43 ` bugzilla-daemon
2011-02-14 15:52 ` bugzilla-daemon
2011-02-14 18:34 ` bugzilla-daemon
2011-02-14 21:06 ` bugzilla-daemon
2011-02-14 21:20 ` bugzilla-daemon
2011-02-14 22:02 ` bugzilla-daemon
2011-02-14 22:42 ` bugzilla-daemon
2011-02-15  9:51 ` bugzilla-daemon
2011-02-15 12:28 ` bugzilla-daemon
2011-02-15 15:00 ` bugzilla-daemon
2011-02-15 21:00 ` bugzilla-daemon
2011-02-15 22:38 ` bugzilla-daemon
2011-02-16  9:50 ` bugzilla-daemon
2011-02-16 10:11 ` bugzilla-daemon
2011-02-16 12:00 ` bugzilla-daemon
2011-02-16 12:15 ` bugzilla-daemon
2011-02-17  0:09 ` bugzilla-daemon
2011-02-17 14:19 ` bugzilla-daemon
2011-02-17 14:50 ` bugzilla-daemon

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20110214130309.91ABA2F78001@mail.ecoscentric.com \
    --to=bugzilla-daemon@bugs.ecos.sourceware.org \
    --cc=ecos-patches@ecos.sourceware.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).