From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: by sourceware.org (Postfix, from userid 48) id 835BB385840C; Thu, 14 Oct 2021 07:00:47 +0000 (GMT) DKIM-Filter: OpenDKIM Filter v2.11.0 sourceware.org 835BB385840C From: "fxue at os dot amperecomputing.com" To: gcc-bugs@gcc.gnu.org Subject: [Bug bootstrap/102681] [12 Regression] AArch64 bootstrap failure Date: Thu, 14 Oct 2021 07:00:47 +0000 X-Bugzilla-Reason: CC X-Bugzilla-Type: changed X-Bugzilla-Watch-Reason: None X-Bugzilla-Product: gcc X-Bugzilla-Component: bootstrap X-Bugzilla-Version: 12.0 X-Bugzilla-Keywords: build, diagnostic X-Bugzilla-Severity: normal X-Bugzilla-Who: fxue at os dot amperecomputing.com X-Bugzilla-Status: NEW X-Bugzilla-Resolution: X-Bugzilla-Priority: P1 X-Bugzilla-Assigned-To: unassigned at gcc dot gnu.org X-Bugzilla-Target-Milestone: 12.0 X-Bugzilla-Flags: X-Bugzilla-Changed-Fields: Message-ID: In-Reply-To: References: Content-Type: text/plain; charset="UTF-8" Content-Transfer-Encoding: quoted-printable X-Bugzilla-URL: http://gcc.gnu.org/bugzilla/ Auto-Submitted: auto-generated MIME-Version: 1.0 X-BeenThere: gcc-bugs@gcc.gnu.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: Gcc-bugs mailing list List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Thu, 14 Oct 2021 07:00:47 -0000 https://gcc.gnu.org/bugzilla/show_bug.cgi?id=3D102681 --- Comment #4 from Feng Xue --- (In reply to Martin Sebor from comment #3) > Simply initializing the variable as in the patch below avoids the warning= .=20 > The control flow in the code is sufficiently opaque to make it worthwhile > from a readability point irrespective of whether or not the variable can,= in > fact, be used uninitialized. >=20 > index e50d3fc3b62..c7f0a405ff6 100644 > --- a/gcc/calls.c > +++ b/gcc/calls.c > @@ -199,7 +199,7 @@ stack_region_maybe_used_p (poly_uint64 lower_bound, > poly_uint64 upper_bound, > static void > mark_stack_region_used (poly_uint64 lower_bound, poly_uint64 upper_bound) > { > - unsigned HOST_WIDE_INT const_lower, const_upper; > + unsigned HOST_WIDE_INT const_lower, const_upper =3D 0; > const_lower =3D constant_lower_bound (lower_bound); > if (upper_bound.is_constant (&const_upper)) > for (unsigned HOST_WIDE_INT i =3D const_lower; i < const_upper; ++i) This code looks good, the warning seems to be an over-kill. Will this change be checked in as a fix?=