From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: by sourceware.org (Postfix, from userid 48) id 8BAA03950416; Wed, 24 Feb 2021 15:23:56 +0000 (GMT) DKIM-Filter: OpenDKIM Filter v2.11.0 sourceware.org 8BAA03950416 From: "iains at gcc dot gnu.org" To: gcc-bugs@gcc.gnu.org Subject: [Bug c++/99215] coroutines: debugging with gdb Date: Wed, 24 Feb 2021 15:23:56 +0000 X-Bugzilla-Reason: CC X-Bugzilla-Type: changed X-Bugzilla-Watch-Reason: None X-Bugzilla-Product: gcc X-Bugzilla-Component: c++ X-Bugzilla-Version: 10.2.1 X-Bugzilla-Keywords: X-Bugzilla-Severity: normal X-Bugzilla-Who: iains at gcc dot gnu.org X-Bugzilla-Status: NEW X-Bugzilla-Resolution: X-Bugzilla-Priority: P3 X-Bugzilla-Assigned-To: unassigned at gcc dot gnu.org X-Bugzilla-Target-Milestone: --- X-Bugzilla-Flags: X-Bugzilla-Changed-Fields: Message-ID: In-Reply-To: References: Content-Type: text/plain; charset="UTF-8" Content-Transfer-Encoding: quoted-printable X-Bugzilla-URL: http://gcc.gnu.org/bugzilla/ Auto-Submitted: auto-generated MIME-Version: 1.0 X-BeenThere: gcc-bugs@gcc.gnu.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: Gcc-bugs mailing list List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Wed, 24 Feb 2021 15:23:56 -0000 https://gcc.gnu.org/bugzilla/show_bug.cgi?id=3D99215 --- Comment #6 from Iain Sandoe --- (In reply to Nils Gladitz from comment #5) > Apparently when the coroutine happens to be a member function (even a sta= tic > one) printing *frame_ptr results in "{}". >=20 > Ideally I'd want to have non-static member coroutines and would like to be > able to inspect the "this" pointer during debugging. .. 'this' gets translated into a reference to the original object for coroutines... hmm have to see if there's any useful advice at this stage. > I was also wondering if "frame_ptr" as a non-reserved name isn't problema= tic > in case there happens to be e.g. a local variable with that name. the local variables in the ramp are prefixed with 'coro.' which makes them = not a legal user identifiers. So it's actually coro.frame_ptr. (where there is potential for clashes, frame variables named are pushed into the implementation space e.g. __ or _CapitalLetter). =3D=3D=3D I should check in the actor/destroyer if there is scope for a clash (since = the variables are local, they are named xxxxxactor:frame_ptr) .. and would be distinct from any var named frame_ptr in the original sourc= e .. which would become xxxxxactor:frame_ptr->frame_ptr :)=20 However, when implementing the "idea" described above, I think that might expose the issue - so prefixing with __ or changing the name to _Frame_ptr might be necessary. Of course, I didn't make a test case to prove this, .. but will try it sometime.=