From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from gate.crashing.org (gate.crashing.org [63.228.1.57]) by sourceware.org (Postfix) with ESMTP id BC34F3877405 for ; Wed, 21 Jul 2021 17:15:24 +0000 (GMT) DMARC-Filter: OpenDMARC Filter v1.4.1 sourceware.org BC34F3877405 Authentication-Results: sourceware.org; dmarc=none (p=none dis=none) header.from=kernel.crashing.org Authentication-Results: sourceware.org; spf=fail smtp.mailfrom=kernel.crashing.org Received: from gate.crashing.org (localhost.localdomain [127.0.0.1]) by gate.crashing.org (8.14.1/8.14.1) with ESMTP id 16LHEODK030731; Wed, 21 Jul 2021 12:14:24 -0500 Received: (from segher@localhost) by gate.crashing.org (8.14.1/8.14.1/Submit) id 16LHENSv030730; Wed, 21 Jul 2021 12:14:23 -0500 X-Authentication-Warning: gate.crashing.org: segher set sender to segher@kernel.crashing.org using -f Date: Wed, 21 Jul 2021 12:14:23 -0500 From: Segher Boessenkool To: Bill Schmidt Cc: gcc-patches@gcc.gnu.org Subject: Re: [PATCH 21/55] rs6000: Write static initializations for built-in table Message-ID: <20210721171423.GI1583@gate.crashing.org> References: Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: User-Agent: Mutt/1.4.2.3i X-Spam-Status: No, score=-5.9 required=5.0 tests=BAYES_00, JMQ_SPF_NEUTRAL, KAM_DMARC_STATUS, TXREP, T_SPF_HELO_PERMERROR, T_SPF_PERMERROR autolearn=no autolearn_force=no version=3.4.4 X-Spam-Checker-Version: SpamAssassin 3.4.4 (2020-01-24) on server2.sourceware.org X-BeenThere: gcc-patches@gcc.gnu.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: Gcc-patches mailing list List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Wed, 21 Jul 2021 17:15:25 -0000 Hi! On Thu, Jun 17, 2021 at 10:19:05AM -0500, Bill Schmidt wrote: > 2021-06-07 Bill Schmidt > > gcc/ > * config/rs6000/rs6000-gen-builtins.c (write_bif_static_init): New > function. > (write_init_file): Call write_bif_static_init. > + for (int j = 0; j < 3; j++) > + res[j] = (bifp->proto.restr_opnd[j] == 0 ? "RES_NONE" > + : (bifp->proto.restr[j] == RES_BITS ? "RES_BITS" > + : (bifp->proto.restr[j] == RES_RANGE ? "RES_RANGE" > + : (bifp->proto.restr[j] == RES_VALUES ? "RES_VALUES" > + : (bifp->proto.restr[j] == RES_VAR_RANGE > + ? "RES_VAR_RANGE" : "ERROR"))))); The unnecessary parens make this harder to read. Having ? on the same line as the condition but : on another is not normal style. Some "if"s would be more readable anyway? Okay for trunk. Thanks! Segher