From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (qmail 31127 invoked by alias); 11 Sep 2003 05:59:34 -0000 Mailing-List: contact gcc-patches-help@gcc.gnu.org; run by ezmlm Precedence: bulk List-Archive: List-Post: List-Help: Sender: gcc-patches-owner@gcc.gnu.org Received: (qmail 31120 invoked from network); 11 Sep 2003 05:59:31 -0000 Received: from unknown (HELO mta1.wss.scd.yahoo.com) (66.218.85.32) by sources.redhat.com with SMTP; 11 Sep 2003 05:59:31 -0000 Received: from specifixinc.com (67.161.44.241) by mta1.wss.scd.yahoo.com (7.0.016) (authenticated as jim@tuliptree.org) id 3F5CE74A0012E648; Wed, 10 Sep 2003 22:59:22 -0700 Message-ID: <3F600F41.9070108@specifixinc.com> Date: Thu, 11 Sep 2003 05:59:00 -0000 From: Jim Wilson User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030716 X-Accept-Language: en-us, en MIME-Version: 1.0 To: Kazu Hirata CC: gcc-patches@gcc.gnu.org Subject: Re: Unreviewed patches References: <20030908.081201.130231675.kazu@cs.umass.edu> Content-Type: text/plain; charset=us-ascii; format=flowed Content-Transfer-Encoding: 7bit X-SW-Source: 2003-09/txt/msg00685.txt.bz2 Kazu Hirata wrote: > [patch] Clean up FUNCTION_ARG_PADDING. > http://gcc.gnu.org/ml/gcc-patches/2003-07/msg00128.html Playing with FUNCTION_ARG_PADDING is very dangerous. You could easily break an ABI, and not realize it until well after a release. Eliminating the duplicate definitions is a good idea though, and the patch does seem reasonably safe. I don't really see the point of making FUNCTION_ARG_PADDING into a function though. None of the other related macros in this file are functions. Why not just rename it to DEFAULT_FUNCTION_ARG_PADDING, and then make that the default definition of FUNCTION_ARG_PADDING? > [patch] combine.c: Convert (ne (and (lshiftrt (xor X CST) Y) 1) 0) into (eq (and (lshiftrt X Y) 1) 0). (take 3) > http://gcc.gnu.org/ml/gcc-patches/2003-08/msg01315.html 1 << INTVAL (shift_count)))) This part can fail. You want to use (HOST_WIDE_INT) 1 instead of just 1, and you need to verify that the shift_mode is smaller than or equal to the size of HOST_WIDE_INT. See similar examples in simplify_shift_const. If handling XOR here makes sense, then does it also make sense in the similar code immediately above? -- Jim Wilson, GNU Tools Support, http://www.SpecifixInc.com