public inbox for gcc-patches@gcc.gnu.org
 help / color / mirror / Atom feed
From: Tobias Burnus <tobias@codesourcery.com>
To: Thomas Schwinge <thomas@codesourcery.com>,
	Frederik Harwath	<frederik@codesourcery.com>,
	<gcc-patches@gcc.gnu.org>
Cc: Jakub Jelinek <jakub@redhat.com>, <fortran@gcc.gnu.org>
Subject: Re: Make OpenACC 'acc_get_property' with 'acc_device_current' work
Date: Mon, 03 Feb 2020 14:41:00 -0000	[thread overview]
Message-ID: <3a3c4a86-2273-2f42-2471-92d9311194b5@codesourcery.com> (raw)
In-Reply-To: <877e19lz2d.fsf@euler.schwinge.homeip.net>

Hi Thomas,

On 1/30/20 4:54 PM, Thomas Schwinge wrote:

>> That's still pending.  Recently,<https://github.com/OpenACC/openacc-spec/issues/256>  "Missing definition
>> for acc_device_current" got filed; let's (also/first) watch/wait what
>> comes out of that.

(Still pending.)

> Please review the attached (Tobias the Fortran test cases, please),
> and test with AMD GCN offloading.  If approving this patch, please respond with
> "Reviewed-by: NAME <EMAIL>" so that your effort will be recorded in the
> commit log, see<https://gcc.gnu.org/wiki/Reviewed-by>.

LGTM with the minor nit regarding the integer kind used
for dev_type (default/unspecified vs. "acc_device_kind").
To make you happy:

Reviewed-by: Tobias Burnus <tobias@codesourcery.com>

Thanks,

Tobias

> --- a/libgomp/openacc.f90
> +++ b/libgomp/openacc.f90
> @@ -766,6 +766,7 @@ module openacc
>   
>     ! From openacc_kinds
>     public :: acc_device_kind
> +  public :: acc_device_current

Good catch!

> +++ b/libgomp/testsuite/libgomp.oacc-fortran/acc_get_property-aux.f90
> …
> +  subroutine expect_device_memory_properties (dev_type, dev_num, &
> +       expected_total_memory)
> +    integer, intent(in) :: dev_type

I think you should use (w/ or w/o "value" attribute)
    integer (acc_device_kind) :: dev_type
instead for consistency. It does not matter in practice but is nicer.

> +       expected_vendor, expected_name, expected_driver)
> +    integer, intent(in) :: dev_type
> +    integer, intent(in) :: dev_num
> +    character*(*), intent(in) :: expected_vendor

Likewise for dev_num.

(Side note: I personally prefer "character(*)" or (even better:) "character(len=*)"
to the "character*…" syntax – as I find it more readable. But that your syntax is
not even marked as obsolescent and, hence, is perfectly valid.)

> +    integer, intent(in) :: dev_num

Ditto.

  parent reply	other threads:[~2020-02-03 14:41 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-12-03 16:51 [PATCH, og8] Add OpenACC 2.6 `acc_get_property' support Maciej W. Rozycki
2018-12-05 10:12 ` Chung-Lin Tang
2018-12-05 18:17   ` Maciej W. Rozycki
2018-12-10  9:06     ` Chung-Lin Tang
2018-12-20 14:25       ` Maciej W. Rozycki
2019-01-08 17:42 ` Thomas Schwinge
2019-10-07 18:41 ` Thomas Schwinge
2019-11-05 15:09   ` Harwath, Frederik
2019-11-14 15:41   ` [PATCH] " Frederik Harwath
2019-12-16 23:06     ` Thomas Schwinge
2019-12-17  9:39       ` Martin Jambor
2019-12-17  9:47       ` Andrew Stubbs
2019-12-20 17:11       ` Harwath, Frederik
2019-12-21 23:01         ` Thomas Schwinge
2019-12-22 22:20           ` Harwath, Frederik
2020-01-10 23:44           ` Thomas Schwinge
2020-01-30 16:14             ` Make OpenACC 'acc_get_property' with 'acc_device_current' work (was: [PATCH] Add OpenACC 2.6 `acc_get_property' support) Thomas Schwinge
2020-02-03 12:16               ` Harwath, Frederik
2020-02-03 14:41               ` Tobias Burnus [this message]
2020-01-16 16:03         ` [PATCH] Add OpenACC 2.6 `acc_get_property' support Thomas Schwinge
2020-01-20 14:20           ` Harwath, Frederik
2020-01-23 15:08             ` Thomas Schwinge
2020-01-24  9:36               ` Harwath, Frederik
2020-01-27 14:57         ` Fortran 'acc_get_property' return type (was: [PATCH] Add OpenACC 2.6 `acc_get_property' support) Thomas Schwinge
2020-01-28 15:31         ` [PATCH] Add OpenACC acc_get_property support for AMD GCN Harwath, Frederik
2020-01-28 16:14           ` Andrew Stubbs
2020-01-29 10:10             ` Harwath, Frederik
2020-01-29 11:07               ` Andrew Stubbs
2020-01-29 11:47                 ` Harwath, Frederik
2020-01-29 17:58               ` Thomas Schwinge
2020-01-29 18:12                 ` Andrew Stubbs
2020-01-30  8:04                 ` Harwath, Frederik
2020-01-30 16:28               ` Thomas Schwinge
2020-01-30 16:54                 ` Andrew Stubbs
2020-01-31  9:32                   ` Thomas Schwinge
2020-01-31 12:32                 ` Harwath, Frederik
2020-01-31 14:49                   ` Thomas Schwinge
2020-04-29  9:19       ` [PATCH] Add OpenACC 2.6 `acc_get_property' support Thomas Schwinge

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=3a3c4a86-2273-2f42-2471-92d9311194b5@codesourcery.com \
    --to=tobias@codesourcery.com \
    --cc=fortran@gcc.gnu.org \
    --cc=frederik@codesourcery.com \
    --cc=gcc-patches@gcc.gnu.org \
    --cc=jakub@redhat.com \
    --cc=thomas@codesourcery.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).