From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (qmail 29497 invoked by alias); 20 Jul 2010 02:27:12 -0000 Received: (qmail 29486 invoked by uid 22791); 20 Jul 2010 02:27:11 -0000 X-SWARE-Spam-Status: No, hits=-5.3 required=5.0 tests=AWL,BAYES_00,RCVD_IN_DNSWL_HI,SPF_HELO_PASS,T_RP_MATCHES_RCVD X-Spam-Check-By: sourceware.org Received: from mx1.redhat.com (HELO mx1.redhat.com) (209.132.183.28) by sourceware.org (qpsmtpd/0.43rc1) with ESMTP; Tue, 20 Jul 2010 02:27:05 +0000 Received: from int-mx02.intmail.prod.int.phx2.redhat.com (int-mx02.intmail.prod.int.phx2.redhat.com [10.5.11.12]) by mx1.redhat.com (8.13.8/8.13.8) with ESMTP id o6K2QqIa026477 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=OK); Mon, 19 Jul 2010 22:26:52 -0400 Received: from anchor.twiddle.home ([10.3.113.74]) by int-mx02.intmail.prod.int.phx2.redhat.com (8.13.8/8.13.8) with ESMTP id o6K2Ql5R002250; Mon, 19 Jul 2010 22:26:47 -0400 Message-ID: <4C450967.9030801@redhat.com> Date: Tue, 20 Jul 2010 02:27:00 -0000 From: Richard Henderson User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.10) Gecko/20100621 Fedora/3.0.5-1.fc13 Thunderbird/3.0.5 MIME-Version: 1.0 To: Kai Tietz CC: Andi Kleen , GCC Patches Subject: Re: [patch i386]: Add for win32 targets pre-prologue profiling feature References: <4C3C942D.3010101@redhat.com> <87630is1gi.fsf@basil.nowhere.org> <4C409173.8000303@redhat.com> In-Reply-To: Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: 7bit X-IsSubscribed: yes Mailing-List: contact gcc-patches-help@gcc.gnu.org; run by ezmlm Precedence: bulk List-Id: List-Archive: List-Post: List-Help: Sender: gcc-patches-owner@gcc.gnu.org X-SW-Source: 2010-07/txt/msg01541.txt.bz2 On 07/16/2010 11:51 PM, Kai Tietz wrote: > +#ifndef MCOUNT_NAME_BEFORE_PROLOGUE > +#define MCOUNT_NAME_BEFORE_PROLOGUE MCOUNT_NAME > +#endif I begin to wonder if it wouldn't be better to just go ahead and use Andi's "__fentry__" symbol for all sub-targets. It's really the only thing that makes sense given the -mfentry option name. > + bool force_default_profile_top_flag = (!TARGET_64BIT && flag_pic); > + default_profile_top_flag = (force_default_profile_top_flag ? 0 : 1); These are confusing names and definitions, because they don't correspond to their names. For instance, f_d_p_t_f does not force the default. It's definition forces p_t_f off. Do you see what I mean? > +#ifndef PROFILE_BEFORE_PROLOGUE > + return false; > +#else > + return true; > +#endif Avoid the double negative in favor of the positive. r~