From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (qmail 3218 invoked by alias); 14 Jul 2011 12:24:48 -0000 Received: (qmail 3206 invoked by uid 22791); 14 Jul 2011 12:24:47 -0000 X-SWARE-Spam-Status: No, hits=-1.8 required=5.0 tests=AWL,BAYES_00,RP_MATCHES_RCVD X-Spam-Check-By: sourceware.org Received: from mail.codesourcery.com (HELO mail.codesourcery.com) (38.113.113.100) by sourceware.org (qpsmtpd/0.43rc1) with ESMTP; Thu, 14 Jul 2011 12:24:27 +0000 Received: (qmail 15743 invoked from network); 14 Jul 2011 12:24:25 -0000 Received: from unknown (HELO ?84.152.205.52?) (bernds@127.0.0.2) by mail.codesourcery.com with ESMTPA; 14 Jul 2011 12:24:25 -0000 Message-ID: <4E1EDFF6.70702@codesourcery.com> Date: Thu, 14 Jul 2011 13:09:00 -0000 From: Bernd Schmidt User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.17) Gecko/20110708 Lightning/1.0b3pre Thunderbird/3.1.10 MIME-Version: 1.0 To: Eric Botcazou CC: GCC Patches , Steve Ellcey , "Vladimir N. Makarov" Subject: Re: Correct fix for scheduler bug PR11320 References: <4E1EBEFE.3080002@codesourcery.com> <201107141357.15147.ebotcazou@adacore.com> <4E1EDDB1.2060008@codesourcery.com> <201107141418.34087.ebotcazou@adacore.com> In-Reply-To: <201107141418.34087.ebotcazou@adacore.com> Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: 7bit Mailing-List: contact gcc-patches-help@gcc.gnu.org; run by ezmlm Precedence: bulk List-Id: List-Archive: List-Post: List-Help: Sender: gcc-patches-owner@gcc.gnu.org X-SW-Source: 2011-07/txt/msg01145.txt.bz2 On 07/14/11 14:18, Eric Botcazou wrote: >> Any particular bits you still see that don't get reverted with this patch? > > The ebb_compute_jump_reg_dependencies changes. The original patch has: > > * sched-ebb.c (compute_jump_reg_dependencies): New prototype. > Mark registers live on entry of the fallthrough block and conditionally > set as set by the jump. Mark registers live on entry of non-fallthrough > blocks as used by the jump. > > but you're reverting only: > > * sched-ebb.c (compute_jump_reg_dependencies): New prototype. > Mark registers live on entry of the fallthrough block and conditionally > set as set by the jump. > ??? Original code: basic_block b = BLOCK_FOR_INSN (insn); edge e; for (e = b->succ; e; e = e->succ_next) ! if ((e->flags & EDGE_FALLTHRU) == 0) ! { ! bitmap_operation (set, set, e->dest->global_live_at_start, ! BITMAP_IOR); ! } } Code after the revert: FOR_EACH_EDGE (e, ei, b->succs) + if ((e->flags & EDGE_FALLTHRU) == 0) bitmap_ior_into (used, df_get_live_in (e->dest)); As far as I can tell these are identical, modulo the change in variable name ("set" -> "used" which seems like a better name). Bernd