public inbox for gcc-patches@gcc.gnu.org
 help / color / mirror / Atom feed
From: David Edelsohn <dje.gcc@gmail.com>
To: Bill Schmidt <wschmidt@linux.ibm.com>
Cc: GCC Patches <gcc-patches@gcc.gnu.org>,
	 Segher Boessenkool <segher@kernel.crashing.org>
Subject: Re: [PATCH 5/6] rs6000: Rename functions with "new" in their names
Date: Tue, 14 Dec 2021 13:08:48 -0500	[thread overview]
Message-ID: <CAGWvny=S3QJSM+tcsAWS9YcsfgN-3_KPc62o0wVv307qY5tQSw@mail.gmail.com> (raw)
In-Reply-To: <26cd500407b755e6c04b6ab045ad65e5dcebcd69.1638820430.git.wschmidt@linux.ibm.com>

On Mon, Dec 6, 2021 at 3:49 PM Bill Schmidt <wschmidt@linux.ibm.com> wrote:
>
> Hi!
>
> While we had two sets of built-in functionality at the same time, I put "new"
> in the names of quite a few functions.  Time to undo that.
>
> Bootstrapped and tested on powerpc64le-linux-gnu with no regressions.  Is this
> okay for trunk?
>
> Thanks!
> Bill
>
> 2021-12-02  Bill Schmidt  <wschmidt@linux.ibm.com>
>
> gcc/
>         * config/rs6000/rs6000-c.c (altivec_resolve_new_overloaded_builtin):
>         Remove forward declaration.
>         (rs6000_new_builtin_type_compatible): Rename to
>         rs6000_builtin_type_compatible.
>         (rs6000_builtin_type_compatible): Remove.
>         (altivec_resolve_overloaded_builtin): Remove.
>         (altivec_build_new_resolved_builtin): Rename to
>         altivec_build_resolved_builtin.
>         (altivec_resolve_new_overloaded_builtin): Rename to
>         altivec_resolve_overloaded_builtin.  Remove static keyword.  Adjust
>         called function names.
>         * config/rs6000/rs6000-call.c (rs6000_expand_new_builtin): Remove
>         forward declaration.
>         (rs6000_gimple_fold_new_builtin): Likewise.
>         (rs6000_invalid_new_builtin): Rename to rs6000_invalid_builtin.
>         (rs6000_gimple_fold_builtin): Remove.
>         (rs6000_new_builtin_valid_without_lhs): Rename to
>         rs6000_builtin_valid_without_lhs.
>         (rs6000_new_builtin_is_supported): Rename to
>         rs6000_builtin_is_supported.
>         (rs6000_gimple_fold_new_mma_builtin): Rename to
>         rs6000_gimple_fold_mma_builtin.
>         (rs6000_gimple_fold_new_builtin): Rename to
>         rs6000_gimple_fold_builtin.  Remove static keyword.  Adjust called
>         function names.
>         (rs6000_expand_builtin): Remove.
>         (new_cpu_expand_builtin): Rename to cpu_expand_builtin.
>         (new_mma_expand_builtin): Rename to mma_expand_builtin.
>         (new_htm_spr_num): Rename to htm_spr_num.
>         (new_htm_expand_builtin): Rename to htm_expand_builtin.  Change name
>         of called function.
>         (rs6000_expand_new_builtin): Rename to rs6000_expand_builtin.  Remove
>         static keyword.  Adjust called function names.
>         (rs6000_new_builtin_decl): Rename to rs6000_builtin_decl.  Remove
>         static keyword.
>         (rs6000_builtin_decl): Remove.
>         * config/rs6000/rs6000-gen-builtins.c (write_decls): In gnerated code,
>         rename rs6000_new_builtin_is_supported to rs6000_builtin_is_supported.
>         * config/rs6000/rs6000-internal.h (rs6000_invalid_new_builtin): Rename
>         to rs6000_invalid_builtin.
>         * config/rs6000/rs6000.c (rs6000_new_builtin_vectorized_function):
>         Rename to rs6000_builtin_vectorized_function.
>         (rs6000_new_builtin_md_vectorized_function): Rename to
>         rs6000_builtin_md_vectorized_function.
>         (rs6000_builtin_vectorized_function): Remove.
>         (rs6000_builtin_md_vectorized_function): Remove.

Okay.

Thanks, David

  parent reply	other threads:[~2021-12-14 18:09 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-12-06 20:49 [PATCH v2 0/6] Remove "old" built-in function infrastructure Bill Schmidt
2021-12-06 20:49 ` [PATCH 1/6] rs6000: Remove new_builtins_are_live and dead code it was guarding Bill Schmidt
2021-12-07  1:09   ` Segher Boessenkool
2021-12-06 20:49 ` [PATCH 2/6] rs6000: Remove altivec_overloaded_builtins array and initialization Bill Schmidt
2021-12-14 17:57   ` [PATCH v2 " Bill Schmidt
2021-12-14 18:04   ` [PATCH " David Edelsohn
2021-12-06 20:49 ` [PATCH 3/6] rs6000: Rename rs6000-builtin-new.def to rs6000-builtins.def Bill Schmidt
2021-12-14 18:00   ` [PATCH v2 " Bill Schmidt
2021-12-14 18:05   ` [PATCH " David Edelsohn
2021-12-06 20:49 ` [PATCH 4/6] rs6000: Remove rs6000-builtin.def and associated data and functions Bill Schmidt
2021-12-14 18:00   ` [PATCH v2 " Bill Schmidt
2021-12-14 18:08   ` [PATCH " David Edelsohn
2021-12-06 20:49 ` [PATCH 5/6] rs6000: Rename functions with "new" in their names Bill Schmidt
2021-12-14 18:01   ` [PATCH v2 /6] " Bill Schmidt
2021-12-14 18:08   ` David Edelsohn [this message]
2021-12-06 20:49 ` [PATCH 6/6] rs6000: Rename arrays to remove temporary _x suffix Bill Schmidt
2021-12-14 18:01   ` [PATCH v2 " Bill Schmidt
2021-12-14 18:10   ` [PATCH " David Edelsohn
2021-12-14 17:32 ` [PATCH v2 0/6] Remove "old" built-in function infrastructure Bill Schmidt
  -- strict thread matches above, loose matches on Subject: below --
2021-12-03 18:22 [PATCH 0/6] rs6000: " Bill Schmidt
2021-12-03 18:22 ` [PATCH 5/6] rs6000: Rename functions with "new" in their names Bill Schmidt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAGWvny=S3QJSM+tcsAWS9YcsfgN-3_KPc62o0wVv307qY5tQSw@mail.gmail.com' \
    --to=dje.gcc@gmail.com \
    --cc=gcc-patches@gcc.gnu.org \
    --cc=segher@kernel.crashing.org \
    --cc=wschmidt@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).