Hi Andrew, all, On 01/12/2022 13:45, Andrew Stubbs wrote: > On 01/12/2022 11:10, Paul-Antoine Arras wrote: >> +      if >> (TARGET_FIJI)                                                         \ >> +    builtin_define >> ("__FIJI__");                                           \ >> +      else if >> (TARGET_VEGA10)                                                  \ >> +    builtin_define >> ("__VEGA10__");                                         \ >> +      else if >> (TARGET_VEGA20)                                                  \ >> +    builtin_define >> ("__VEGA20__");                                         \ >> +      else if >> (TARGET_GFX908)                                                  \ >> +    builtin_define >> ("__GFX908__");                                         \ >> +      else if >> (TARGET_GFX90a)                                                  \ >> +    builtin_define >> ("__GFX90a__");                                         \ >> +  } while (0) >> > > I don't think it makes sense to say __VEGA10__ when the user asked for > -march=gfx900. > > This whole naming thing is a bit of a mess already, so I think we'd do > better to either keep the same names throughout or match what LLVM does > (since it got to these first). > > Please use "__gfx900__" etc. (lower case). > > [...] > > P.S. If you want to split the patch into the GCN bits and the bits that > depend on metadirectives then we can apply the first part to mainline > right away. I believe this patch addresses your comments regarding the GCN bits. The new builtins are consistent with the LLVM naming convention (lower case, canonical name). For gfx803, I also kept '__fiji__' to be consistent with -march=fiji. Is it OK for mainline? Thanks, -- PA