public inbox for gcc-patches@gcc.gnu.org
 help / color / mirror / Atom feed
* [PATCH 0/6] rs6000: Remove "old" built-in function infrastructure
@ 2021-12-03 18:22 Bill Schmidt
  2021-12-03 18:22 ` [PATCH 2/6] rs6000: Remove altivec_overloaded_builtins array and initialization Bill Schmidt
                   ` (5 more replies)
  0 siblings, 6 replies; 7+ messages in thread
From: Bill Schmidt @ 2021-12-03 18:22 UTC (permalink / raw)
  To: gcc-patches; +Cc: segher, dje, Bill Schmidt

From: Bill Schmidt <wschmidt@linux.ibm.com>

Hi!

Now that the new built-in function support is all upstream and enabled, it
seems safe and prudent to remove the old code to avoid confusion.  I broke this
up to the extent possible, but the first patch is a bit large and messy because
so many dead functions have to be removed when taking out the
"new_builtins_are_live" variable.

Bill Schmidt (6):
  rs6000: Remove new_builtins_are_live and dead code it was guarding
  rs6000: Remove altivec_overloaded_builtins array and initialization
  rs6000: Rename rs6000-builtin-new.def to rs6000-builtins.def
  rs6000: Remove rs6000-builtin.def and associated data and functions
  rs6000: Rename functions with "new" in their names
  rs6000: Rename arrays to remove temporary _x suffix

 gcc/config/rs6000/darwin.h                    |     8 +-
 gcc/config/rs6000/rs6000-builtin.def          |  3350 ---
 ...00-builtin-new.def => rs6000-builtins.def} |     0
 gcc/config/rs6000/rs6000-c.c                  |  1342 +-
 gcc/config/rs6000/rs6000-call.c               | 17810 +++-------------
 gcc/config/rs6000/rs6000-gen-builtins.c       |   115 +-
 gcc/config/rs6000/rs6000-internal.h           |     2 +-
 gcc/config/rs6000/rs6000-protos.h             |     3 -
 gcc/config/rs6000/rs6000.c                    |   334 +-
 gcc/config/rs6000/rs6000.h                    |    58 -
 gcc/config/rs6000/t-rs6000                    |     7 +-
 11 files changed, 3173 insertions(+), 19856 deletions(-)
 delete mode 100644 gcc/config/rs6000/rs6000-builtin.def
 rename gcc/config/rs6000/{rs6000-builtin-new.def => rs6000-builtins.def} (100%)

-- 
2.27.0


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2021-12-06 16:39 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-12-03 18:22 [PATCH 0/6] rs6000: Remove "old" built-in function infrastructure Bill Schmidt
2021-12-03 18:22 ` [PATCH 2/6] rs6000: Remove altivec_overloaded_builtins array and initialization Bill Schmidt
2021-12-03 18:22 ` [PATCH 3/6] rs6000: Rename rs6000-builtin-new.def to rs6000-builtins.def Bill Schmidt
2021-12-03 18:22 ` [PATCH 4/6] rs6000: Remove rs6000-builtin.def and associated data and functions Bill Schmidt
2021-12-03 18:22 ` [PATCH 5/6] rs6000: Rename functions with "new" in their names Bill Schmidt
2021-12-03 18:22 ` [PATCH 6/6] rs6000: Rename arrays to remove temporary _x suffix Bill Schmidt
2021-12-06 16:39 ` [PATCH 0/6] rs6000: Remove "old" built-in function infrastructure Bill Schmidt

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).