public inbox for gcc-patches@gcc.gnu.org
 help / color / mirror / Atom feed
From: "Kewen.Lin" <linkw@linux.ibm.com>
To: Martin Sebor <msebor@gmail.com>
Cc: GCC Patches <gcc-patches@gcc.gnu.org>,
	Segher Boessenkool <segher@kernel.crashing.org>,
	Bill Schmidt <wschmidt@linux.ibm.com>,
	Richard Biener <richard.guenther@gmail.com>
Subject: Re: predcom: Refactor more by encapsulating global states
Date: Thu, 24 Jun 2021 17:26:36 +0800	[thread overview]
Message-ID: <f83446b5-648c-7f9f-1d11-e5d53b409804@linux.ibm.com> (raw)
In-Reply-To: <a8fb16ef-c67d-9969-4b59-7b06150cad0e@gmail.com>

Hi Martin,

on 2021/6/23 上午12:14, Martin Sebor wrote:
> On 6/21/21 8:35 PM, Kewen.Lin wrote:
>> Hi Richi and Martin,
>>
>>>>
>>>> Thanks Richi!  One draft (not ready for review) is attached for the further
>>>> discussion.  It follows the idea of RAII-style cleanup.  I noticed that
>>>> Martin suggested stepping forward to make tree_predictive_commoning_loop
>>>> and its callees into one class (Thanks Martin), since there are not many
>>>> this kind of C++-style work functions, I want to double confirm which option
>>>> do you guys prefer?
>>>>
>>>
>>> Such general cleanup is of course desired - Giuliano started some of it within
>>> GSoC two years ago in the attempt to thread the compilation process.  The
>>> cleanup then helps to get rid of global state which of course interferes here
>>> (and avoids unnecessary use of TLS vars).
>>>
>>> So yes, encapsulating global state into a class and making accessors
>>> member functions is something that is desired (but a lot of mechanical
>>> work).
>>>
>>> Thanks
>>> Richard.
>>>
>>> I meant that not necessarily as something to include in this patch
>>> but as a suggestion for a future improvement.  If you'd like to
>>> tackle it at any point that would be great of course   In any
>>> event, thanks for double-checking!
>>>
>>> The attached patch looks good to me as well (more for the sake of
>>> style than anything else, declaring the class copy ctor and copy assignment = delete would > make it clear it's not meant to be
>>> copied, although in this case it's unlikely to make a practical
>>> difference).
>>>
>>> Martin.
>>
>>
>> Thanks for your explanation!  Sorry for the late response.
>> As the way to encapsulate global state into a class and making accessors
>> member functions looks more complete, I gave up the RAII draft and
>> switched onto this way.
>>
>> This patch is to encapsulate global states into a class and
>> making their accessors as member functions, remove some
>> consequent useless clean up code, and do some clean up with
>> RAII.
> 
> Nice!
> 
> A further improvement worth considering (if you're so inclined :)
> is replacing the pcom_worker vec members with auto_vec (obviating
> having to explicitly release them) and for the same reason also
> replacing the comp_ptrs bare pointer members with auto_vecs.
> There may be other opportunities to do the same in individual
> functions (I'd look to get rid of as many calls to functions
> like XNEW()/XNEWVEC() and free() use auto_vec instead).
> 
> An unrelated but worthwhile change is to replace the FOR_EACH_
> loops with C++ 11 range loops, analogously to:
> https://gcc.gnu.org/pipermail/gcc-patches/2021-June/572315.html
> 
> Finally, the only loosely followed naming convention for member
> variables is to start them with the m_ prefix.
> 
> These just suggestions that could be done in a followup, not
> something I would consider prerequisite for accepting the patch
> as is if I were in a position to make such a decision.
> 

Many thanks for all the great suggestions!  I'll deal with them
in a follow up patch.


BR,
Kewen

  reply	other threads:[~2021-06-24  9:26 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-06-02  9:29 [PATCH] predcom: Adjust some unnecessary update_ssa calls Kewen.Lin
2021-06-07 14:46 ` Richard Biener
2021-06-07 15:20   ` Martin Sebor
2021-06-08  9:30   ` Kewen.Lin
2021-06-08 11:02     ` Richard Biener
2021-06-08 11:09       ` Richard Biener
2021-06-22  2:35       ` predcom: Refactor more by encapsulating global states Kewen.Lin
2021-06-22 16:14         ` Martin Sebor
2021-06-24  9:26           ` Kewen.Lin [this message]
2021-07-19  6:28             ` [PATCH] predcom: Refactor more using auto_vec Kewen.Lin
2021-07-19 20:45               ` Martin Sebor
2021-07-20  2:04                 ` Kewen.Lin
2021-07-20 11:19               ` Richard Biener
2021-06-23  7:22         ` predcom: Refactor more by encapsulating global states Richard Biener
2021-06-24  9:28           ` Kewen.Lin
2021-06-08 14:26     ` [PATCH] predcom: Adjust some unnecessary update_ssa calls Martin Sebor

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f83446b5-648c-7f9f-1d11-e5d53b409804@linux.ibm.com \
    --to=linkw@linux.ibm.com \
    --cc=gcc-patches@gcc.gnu.org \
    --cc=msebor@gmail.com \
    --cc=richard.guenther@gmail.com \
    --cc=segher@kernel.crashing.org \
    --cc=wschmidt@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).