public inbox for gcc@gcc.gnu.org
 help / color / mirror / Atom feed
From: Segher Boessenkool <segher@kernel.crashing.org>
To: Arvind Sankar <nivedita@alum.mit.edu>
Cc: gcc@gcc.gnu.org
Subject: Re: Use predicates for RTL objects
Date: Wed, 07 Aug 2019 18:05:00 -0000	[thread overview]
Message-ID: <20190807180551.GX31406@gate.crashing.org> (raw)
In-Reply-To: <20190807173952.GA3751941@rani.riverdale.lan>

On Wed, Aug 07, 2019 at 01:39:53PM -0400, Arvind Sankar wrote:
> On Wed, Aug 07, 2019 at 12:33:53PM -0500, Segher Boessenkool wrote:
> > On Wed, Aug 07, 2019 at 12:15:29PM -0400, Arvind Sankar wrote:
> > > I would also like to get some comments on the following idea to make the
> > > code checks more readable: I am thinking of adding
> > > 	bool rtx_def::is_a (enum rtx_code) const
> > > This would allow us to make all the rtx_code comparisons more readable
> > > without having to define individual macros for each.
> > > i.e.,
> > > 	REG_P (x)			   => x->is_a (REG)
> > > 	GET_CODE (x) == PLUS		   => x->is_a (PLUS)
> > > 	GET_CODE (PATTERN (x)) == SEQUENCE => PATTERN (x)->is_a (SEQUENCE)
> > 
> > That makes things much worse.  Not only is it less readable (IMO), but
> > the "is_a" idiom is used to check if something is of a certain class,
> > which is not the case here.
> 
> Well, the rtx_code *is* kind of a class. It determines what fields of
> the rtx are valid and what they contain etc.

It is not a class in the C++ sense.  Confusing this is not useful for
anyone.

> > In "GET_CODE (x) == PLUS" it is clear that what the resulting machine
> > code does is cheap.  With "x->is_a (PLUS)", who knows what is happening
> > below the covers!
> 
> We already have, for eg, is_a <rtx_sequence *> (x), and there are

Whis *is* a class.  And not all of us are happy with that, but since we
don't often have to see it at all, it's not so bad.

Having rtx_insn a separate type from rtx is actually useful, btw.

> predicate macros whose implementation is more complex than checking the
> code field. You basically have to trust that it's sensibly implemented,
> i.e. that it is as efficiently implemented as it can be.

That's not my point -- my point was that it is *obvious* the way things
are now, which is nice.

> I don't think
> people writing RTL transformations should be overly worried about what
> machine code their predicates are generating, especially when
> they're calling the defined API for it.

The whole *design* of RTL is based around us caring a whole lot.

> > (And "REG_P" and similar are much shorter code to type).
> 
> That is true for the ones that exist, but there are lots more that don't
> and it doesn't really make sense to add individual macros for all of
> them.

Yes.  So use GET_CODE for those?  REG_P is super frequent, it is really
handy to have a macro for it.


If you really want to convert RTL to C++, you should start with getting
rid of rtx_format and rtx_class, and make REG_P etc. work just as they
have always done.


Segher

  reply	other threads:[~2019-08-07 18:05 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-08-07 16:15 Arvind Sankar
2019-08-07 17:33 ` Segher Boessenkool
2019-08-07 17:40   ` Arvind Sankar
2019-08-07 18:05     ` Segher Boessenkool [this message]
2019-08-07 18:58       ` Arvind Sankar
2019-08-08 15:04         ` Segher Boessenkool
2019-08-08 17:42           ` Arvind Sankar
2019-08-08 18:26             ` Segher Boessenkool
2019-08-08 18:53               ` Arvind Sankar
2019-08-08 20:28             ` Jeff Law
2019-08-08  9:10       ` Richard Sandiford
2019-08-08 15:28         ` Segher Boessenkool
2019-08-08 14:31       ` Jeff Law
2019-08-08 15:36         ` Segher Boessenkool
2019-08-08 17:07         ` Arvind Sankar
2019-08-08 20:11           ` Jeff Law
2019-08-09  8:06   ` Richard Biener
2019-08-08 15:04 ` Michael Matz
2019-08-08 17:12   ` Arvind Sankar
2019-08-08 18:14     ` Jakub Jelinek
2019-08-08 18:35       ` Arvind Sankar
2019-08-08 18:46         ` Jakub Jelinek
2019-08-08 20:32           ` Jeff Law
  -- strict thread matches above, loose matches on Subject: below --
2006-02-03  4:23 nathan bullock
2006-02-03  5:46 ` Ben Elliston

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190807180551.GX31406@gate.crashing.org \
    --to=segher@kernel.crashing.org \
    --cc=gcc@gcc.gnu.org \
    --cc=nivedita@alum.mit.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).