public inbox for gcc@gcc.gnu.org
 help / color / mirror / Atom feed
From: Nix <nix@esperi.demon.co.uk>
To: Jeff Garzik <jgarzik@mandrakesoft.com>
Cc: gcc@gcc.gnu.org
Subject: Re: bootstrapping with profiling feedback?
Date: Tue, 30 Jul 2002 05:50:00 -0000	[thread overview]
Message-ID: <87d6t69kqy.fsf@amaterasu.srvr.nix> (raw)
In-Reply-To: <3D407F7B.4050103@mandrakesoft.com>

On Thu, 25 Jul 2002, Jeff Garzik spake:
> I'm assuming an implementation would look something like:
> 
> build stage1 using platform compiler
> build stage2 using stage1 and -fprofile-arcs
> build stage3 using stage2 and -fbranch-probabilities
> build stage4 using stage3 and -fbranch-probabilities
> compare stage 3 and 4 .o files
> 
> Maybe this could be called "make profilestrap"?  ;-)

I'd like that too; but I'd be just as happy to have a slightly different
target that builds stage1 with -fprofile-arcs -ftest-coverage, and
likewise for everything else (right up tot the libraries and testsuite),
so we can see how much of the (machine-independent and relevant
-dependent) parts of the compiler is actually being tested by a
bootstrap&test run.

(We might have to unconditionally turn off one or all of these flags for
the appropriate parts of profile.c and/or libgcc2.c themselves :) a small
loss, we'll *know* they're being tested...)


Pie-in-the-sky, I dream of a target that just runs the testsuite with a
compiler with test-coverage turned on, but builds libraries and things
without that flag, so we can tell how much of the compiler the testsuite
alone is testing; the whole-lot results might be perturbed by changes in
the compiler, but if we are testing part of the compiler via the
testsuite, it's reasonable to suppose that it'll stay tested :)

-- 
`There's something satisfying about killing JWZ over and over again.'
                                        -- 1i, personal communication

      reply	other threads:[~2002-07-29 23:30 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2002-07-26  7:05 Jeff Garzik
2002-07-30  5:50 ` Nix [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87d6t69kqy.fsf@amaterasu.srvr.nix \
    --to=nix@esperi.demon.co.uk \
    --cc=gcc@gcc.gnu.org \
    --cc=jgarzik@mandrakesoft.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).