public inbox for gcc@gcc.gnu.org
 help / color / mirror / Atom feed
From: Nix <nix@esperi.demon.co.uk>
To: "Zack Weinberg" <zackw@stanford.edu>
Cc: gcc@gcc.gnu.org
Subject: Re: Libgcc symbols
Date: Mon, 16 Apr 2001 11:00:00 -0000	[thread overview]
Message-ID: <87d7acivqc.fsf@loki.wkstn.nix> (raw)
In-Reply-To: <20010416090821.L339@stanford.edu>

On Mon, 16 Apr 2001, Zack Weinberg yowled:
> On Mon, Apr 16, 2001 at 12:56:59PM +0100, Nix wrote:
>> >    __dummy
>> 
>> This one *must* be dead. It is referenced nowhere in the tree, and it
>> calls __builtin_saveregs by name --- not the target-specific
>> version. Anyone that did *that* in the last few years would have
>> aborted. This should die.
> 
> I think you've mixed up __dummy with the code immediately following
> it.

Owch, yes. What an embarrassing mistake. However, I was using a mono
terminal over a slow link at the time, so I didn't have fontification or
anything to help.

> It shouldn't be _that_ hard to change i860_saveregs to emit in-line
> code the same way all the others do, and then this can disappear.  Or
> the logic could be moved to config/i860/lib1funcs.asm.

That makes a *lot* of sense. If this isn't target-specific code,
*nothing* is :)

>> The name has been recycled in libstdc++-v3, but only the name; it
>> shouldn't generate external references. (Of course, one typo and it
>> *will*, and all hell may break loose. I doubt that though.)
>> 
>> It's also been recycled by libio, wrapped in a mess of macros to confuse
>> people into thinking that this is a reference to the function. Gaah.
> 
> Appears to be used only as a template parameter or variable name, so
> should be harmless.

I fear I was unclear. I meant that the *name* has been recycled. It's
not a reference to __dummy.

> winds up defining a structure field named __dummy, which is a function
> pointer; again, no danger of clash here.

That's what I was saying :)

> Why we still have libio in-tree at all is another question.  (I have
> never understood why iostreams aren't a layer of paint on top of
> the public stdio interface.)

If you want to have your ears burned off, talk to Ian Jackson on the
subject. He, er, dislikes it too. Quite strongly, one might say.

-- 
`... and it's not true that I'm closely related to the three-toed
 sloth.' --- Kieran

  parent reply	other threads:[~2001-04-16 11:00 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2001-04-13 21:11 Mark Mitchell
2001-04-14  8:02 ` law
2001-04-16  5:54 ` Nix
2001-04-16  9:08   ` Zack Weinberg
2001-04-16  9:28     ` Phil Edwards
2001-04-16  9:44       ` Zack Weinberg
2001-04-16 10:43         ` Gabriel Dos Reis
2001-04-16 11:52         ` Phil Edwards
2001-04-16 10:39       ` Gabriel Dos Reis
2001-04-16 11:00     ` Nix [this message]
2001-04-17 11:23     ` Richard Henderson
2001-04-17 16:17     ` Joern Rennecke
2001-04-16 10:17   ` Profiling with '-a' [was Re: Libgcc symbols] Scott A Crosby
2001-04-16 15:01     ` Nix
2001-04-16 11:06   ` Libgcc symbols Mark Mitchell
2001-04-17 16:10 ` Michael Meissner
2001-04-17 17:57   ` Joe Buck
2001-04-17 23:11     ` Russ Allbery
2001-04-17 23:14       ` Russ Allbery
2001-04-16  9:35 Richard Kenner
2001-04-16 12:22 ` Alexandre Oliva
2001-04-16 12:25 Richard Kenner
2001-04-16 12:48 ` Alexandre Oliva
2001-04-17 11:29 ` Richard Henderson
2001-04-16 12:49 Richard Kenner
2001-04-16 12:58 dewar
2001-04-17 11:33 Richard Kenner
2001-04-17 12:14 dewar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87d7acivqc.fsf@loki.wkstn.nix \
    --to=nix@esperi.demon.co.uk \
    --cc=gcc@gcc.gnu.org \
    --cc=zackw@stanford.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).