public inbox for gcc@gcc.gnu.org
 help / color / mirror / Atom feed
From: Nix <nix@esperi.org.uk>
To: Joe Buck <Joe.Buck@synopsys.COM>
Cc: gcc@gcc.gnu.org
Subject: Re: SEGV building qt-3.3.3 with GCC 3.4.3 on RH 7.1/RHEL 2.1
Date: Tue, 07 Dec 2004 15:56:00 -0000	[thread overview]
Message-ID: <87oeh6kspz.fsf@amaterasu.srvr.nix> (raw)
In-Reply-To: <20041202160806.A1814@synopsys.com> (Joe Buck's message of "3 Dec 2004 00:08:38 -0000")

On 3 Dec 2004, Joe Buck said:
>                                 If the blowup is in a place where there
> appears to be no code, it's probably in a destructor.

I've also seen sibcalls trigger this in cases where the sibcalled
function's prototype is different from its declaration; when the
sibcalled function returns, you can get a segfault because sibcalling
kicked in when the function's true declaration would have suppressed
it, and the return mangles the stack.

(Of course GCC warns about this case, and of course it couldn't be the
cause of a crash at the end of main(), as main() can't be sibcalled. Now
we're using -funit-at-a-time for everything, GCC may well be smart
enough to spot that sibcalling is unusable even in the presence of this
programmer error.)

-- 
`The sword we forged has turned upon us
 Only now, at the end of all things do we see
 The lamp-bearer dies; only the lamp burns on.'

  parent reply	other threads:[~2004-12-07 15:56 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2004-12-02 22:33 Albert Chin
2004-12-03  0:08 ` Joe Buck
2004-12-03 17:13   ` Albert Chin
2004-12-07 15:56   ` Nix [this message]
2004-12-09 20:46   ` Michael Matz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87oeh6kspz.fsf@amaterasu.srvr.nix \
    --to=nix@esperi.org.uk \
    --cc=Joe.Buck@synopsys.COM \
    --cc=gcc@gcc.gnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).