public inbox for gdb-patches@sourceware.org
 help / color / mirror / Atom feed
From: Joel Brobecker <brobecker@adacore.com>
To: Jan Kratochvil <jan.kratochvil@redhat.com>
Cc: Thiago Jung Bauermann <bauerman@br.ibm.com>,
	Pedro Alves <pedro@codesourcery.com>,
	gdb-patches@sourceware.org
Subject: Re: [patch 1/2] Convert hardware watchpoints to use breakpoint_ops
Date: Tue, 16 Nov 2010 08:07:00 -0000	[thread overview]
Message-ID: <20101116080721.GC4434@adacore.com> (raw)
In-Reply-To: <20101116040625.GB19243@host0.dyn.jankratochvil.net>

> > -static void
> > -insert_catch_fork (struct breakpoint *b)
> > +static int
> > +insert_catch_fork (struct bp_location *b)
> 
> Such variables (across the whole patch) should be really renamed when
> changing its type.

How about doing such a rename as a patch on its own?  I've spent
a fair amount of time thinking about this patch, and I'd rather not
have to review it again if the changes are only going to be minor
and not affect behavior.

I don't have any issue with blocking checkin of this patch until patches
implementing your suggestions are approved, if that helps.  I just
would rather avoid having to re-review the same patch again. Knowing
how git works, this shouldn't be very hard to do.

(notice: IIRC, when I first looked at patch #2, one of my reactions
is that I wanted to see the patch split-up in several smaller pieces;
I will explain that when I get to that patch)

> Also were these functions intended per-breakpoint or per-bp_location?
> It looks to me currently they are used only for single-location
> breakpoint so no one knows.  (I guess they were meant for breakpoint.)

I think that eventually, we want them to be per bp-location.  It does
not matter right now, as you say, since they are only used for single-
location breakpoints.

That's a good point, though. Perhaps a documentation update can help
make that clearer. OK with a separate patch?

> > -  void (*insert) (struct breakpoint *);
> > +  /* Insert the breakpoint or watchpoint or activate the catchpoint.
> > +     Return 0 for success, 1 if the breakpoint, watchpoint or catchpoint
> > +     type is not supported, -1 for failure.  */
> > +  int (*insert) (struct bp_location *);
[...]
> At least rename it to insert_bploc (or insert_location etc.).  This
> will need to be cleaned up with the regular breakpoints/watchpoints
> conversion to breakpoint_ops.

I don't feel that strongly about it. I don't feel that renaming
"insert" that takes a bp_loc into "insert_bploc" is going to help
much. But I'm OK.  I am suggesting that we push that as a followup
patch, if that's OK with you, just to ease review of that change
alone.

-- 
Joel

  reply	other threads:[~2010-11-16  8:07 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-08-17 19:41 Thiago Jung Bauermann
2010-10-07 14:47 ` Thiago Jung Bauermann
2010-10-16 17:43 ` Pedro Alves
2010-10-20  0:31   ` Thiago Jung Bauermann
2010-11-04 21:17     ` Thiago Jung Bauermann
2010-11-08 18:43     ` Joel Brobecker
2010-11-08 21:39       ` Thiago Jung Bauermann
2010-11-15 22:23     ` Joel Brobecker
2010-11-16 19:03       ` Thiago Jung Bauermann
2010-11-18 17:18         ` Joel Brobecker
2010-11-19 20:10           ` Thiago Jung Bauermann
2010-12-23 19:06             ` Thiago Jung Bauermann
2011-01-11 19:31               ` Thiago Jung Bauermann
2011-04-29 15:51                 ` "Cannot remove breakpoints because program is no longer writable" & catchpoints (was: Re: [patch 1/2] Convert hardware watchpoints to use breakpoint_ops) Pedro Alves
2010-11-16  4:06     ` [patch 1/2] Convert hardware watchpoints to use breakpoint_ops Jan Kratochvil
2010-11-16  8:07       ` Joel Brobecker [this message]
2010-11-16 18:51         ` Jan Kratochvil
2010-11-17  3:47           ` [patch] Renaming: {insert,remove} += _location [Re: [patch 1/2] Convert hardware watchpoints to use breakpoint_ops] Jan Kratochvil
2010-11-18 17:13             ` Joel Brobecker
2010-11-17  3:47           ` [patch] renaming: bp_location: b->bl &co. " Jan Kratochvil
2010-11-18 17:15             ` Joel Brobecker
2010-12-23 18:50             ` Thiago Jung Bauermann
2010-12-24  5:14               ` Joel Brobecker
2010-12-27 20:04                 ` Thiago Jung Bauermann

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20101116080721.GC4434@adacore.com \
    --to=brobecker@adacore.com \
    --cc=bauerman@br.ibm.com \
    --cc=gdb-patches@sourceware.org \
    --cc=jan.kratochvil@redhat.com \
    --cc=pedro@codesourcery.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).