public inbox for gdb-patches@sourceware.org
 help / color / mirror / Atom feed
From: Gary Benson <gbenson@redhat.com>
To: Pedro Alves <palves@redhat.com>
Cc: Siva Chandra <sivachandra@google.com>,
	       gdb-patches <gdb-patches@sourceware.org>
Subject: Re: [PATCH 11/15] Rename functions and make nonstatic as necessary
Date: Wed, 18 Jun 2014 14:09:00 -0000	[thread overview]
Message-ID: <20140618140952.GA28449@blade.nx> (raw)
In-Reply-To: <53A19A53.6030107@redhat.com>

Pedro Alves wrote:
> On 06/18/2014 02:28 PM, Gary Benson wrote:
> > Siva Chandra wrote:
> > > On Tue, Jun 17, 2014 at 7:12 AM, Gary Benson <gbenson@redhat.com> wrote:
> > > > This commit renames the functions that are to be shared.
> > > > Functions to be shared that were static are made nonstatic.
> > >

> > > I thinking making the functions nonstatic in this part was
> > > not correct. The build currently fails when built with
> > > "-Werror=missing-prototypes" as 14/15 has not yet been
> > > committed.
> > 
> > My apologies Siva.
> > 
> > Pedro, should I commit the remaining piece now, and work on the
> > i386_insert_hw_breakpoint as a separate patch?
> 
> As you've committed the header patch already, I think the issue
> is actually already fixed?

Ah, ok, I misunderstood.  I can stop rushing!

I actually wish I hadn't committed the header patch now, the
i386_{insert,remove}_hw_breakpoint refactoring you spotted
means those functions didn't need exposing at all.

I'm working on a patch to revert part of that change: remove the
prototypes, make them static again, *and* rename the now static
functions them back to their original names.  The last point isn't
strictly necessary, but I don't like that the refactoring would
have renamed some functions it didn't need to.  I want to put the
old names back so that people familiar with that code don't see
more disruption than strictly necessary.

I was going to mail it alone (I thought Siva was stuck) but since
he's not I'll mail it as part of a three-patch series to complete
the refactoring.

Thanks,
Gary

-- 
http://gbenson.net/

  parent reply	other threads:[~2014-06-18 14:09 UTC|newest]

Thread overview: 45+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-06-17 14:13 [PATCH 00/15] Refactor shared code in i386-{nat,low}.[ch] Gary Benson
2014-06-17 14:13 ` [PATCH 04/15] Comment changes Gary Benson
2014-06-17 15:45   ` Pedro Alves
2014-06-17 16:10     ` Gary Benson
2014-06-17 17:11       ` Pedro Alves
2014-06-17 14:13 ` [PATCH 01/15] Whitespace changes Gary Benson
2014-06-17 15:23   ` Pedro Alves
2014-06-17 14:13 ` [PATCH 03/15] Remove unused macro Gary Benson
2014-06-17 15:35   ` Pedro Alves
2014-06-17 14:40 ` [PATCH 06/15] Merge printing code Gary Benson
2014-06-17 16:01   ` Pedro Alves
2014-06-17 14:40 ` [PATCH 14/15] Create nat/i386-dregs.c Gary Benson
2014-06-17 16:56   ` Pedro Alves
2014-06-18 13:43     ` Gary Benson
2014-06-17 14:44 ` [PATCH 09/15] Merge i386_update_inferior_debug_regs Gary Benson
2014-06-17 16:06   ` Pedro Alves
2014-06-17 14:44 ` [PATCH 12/15] Create nat/i386-dregs.h Gary Benson
2014-06-17 16:48   ` Pedro Alves
2014-06-18 11:14     ` Gary Benson
2014-06-17 14:48 ` [PATCH 07/15] Merge error handling Gary Benson
2014-06-17 16:02   ` Pedro Alves
2014-06-17 14:48 ` [PATCH 11/15] Rename functions and make nonstatic as necessary Gary Benson
2014-06-17 16:13   ` Pedro Alves
2014-06-18 10:25   ` Siva Chandra
2014-06-18 13:30     ` Gary Benson
2014-06-18 13:55       ` Pedro Alves
2014-06-18 14:03         ` Siva Chandra
2014-06-18 14:09         ` Gary Benson [this message]
2014-06-18 14:18           ` Pedro Alves
2014-06-17 14:53 ` [PATCH 02/15] Remove unnecessary prototypes Gary Benson
2014-06-17 15:26   ` Pedro Alves
2014-06-17 14:53 ` [PATCH 08/15] Rename maint_show_dr to debug_hw_points Gary Benson
2014-06-17 16:03   ` Pedro Alves
2014-06-17 14:53 ` [PATCH 05/15] Add a const Gary Benson
2014-06-17 15:46   ` Pedro Alves
2014-06-17 14:53 ` [PATCH 10/15] Abstract i386_dr_low access Gary Benson
2014-06-17 16:10   ` Pedro Alves
2014-06-17 14:58 ` [PATCH 13/15] Move macros from i386-{nat,low}.c to i386-{nat,low}.h Gary Benson
2014-06-17 16:54   ` Pedro Alves
2014-06-18 11:33     ` Gary Benson
2014-06-18 11:50       ` Pedro Alves
2014-06-17 14:58 ` [PATCH 15/15] Buildsystem changes Gary Benson
2014-06-17 16:41   ` Pedro Alves
2014-06-17 17:00 ` [PATCH 00/15] Refactor shared code in i386-{nat,low}.[ch] Pedro Alves
2014-06-18 10:49   ` Gary Benson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140618140952.GA28449@blade.nx \
    --to=gbenson@redhat.com \
    --cc=gdb-patches@sourceware.org \
    --cc=palves@redhat.com \
    --cc=sivachandra@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).