From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (qmail 19207 invoked by alias); 11 Nov 2014 18:53:32 -0000 Mailing-List: contact gdb-patches-help@sourceware.org; run by ezmlm Precedence: bulk List-Id: List-Subscribe: List-Archive: List-Post: List-Help: , Sender: gdb-patches-owner@sourceware.org Received: (qmail 19197 invoked by uid 89); 11 Nov 2014 18:53:31 -0000 Authentication-Results: sourceware.org; auth=none X-Virus-Found: No X-Spam-SWARE-Status: No, score=-2.3 required=5.0 tests=AWL,BAYES_00,RP_MATCHES_RCVD,SPF_HELO_PASS,SPF_PASS autolearn=ham version=3.3.2 X-HELO: mx1.redhat.com Received: from mx1.redhat.com (HELO mx1.redhat.com) (209.132.183.28) by sourceware.org (qpsmtpd/0.93/v0.84-503-g423c35a) with (AES256-GCM-SHA384 encrypted) ESMTPS; Tue, 11 Nov 2014 18:53:30 +0000 Received: from int-mx11.intmail.prod.int.phx2.redhat.com (int-mx11.intmail.prod.int.phx2.redhat.com [10.5.11.24]) by mx1.redhat.com (8.14.4/8.14.4) with ESMTP id sABIrSq8003141 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-GCM-SHA384 bits=256 verify=FAIL) for ; Tue, 11 Nov 2014 13:53:29 -0500 Received: from [127.0.0.1] (ovpn01.gateway.prod.ext.ams2.redhat.com [10.39.146.11]) by int-mx11.intmail.prod.int.phx2.redhat.com (8.14.4/8.14.4) with ESMTP id sABIrRLM016573; Tue, 11 Nov 2014 13:53:27 -0500 Message-ID: <54625B26.8000309@redhat.com> Date: Tue, 11 Nov 2014 18:53:00 -0000 From: Pedro Alves User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.1.1 MIME-Version: 1.0 To: Jan Kratochvil , gdb-patches@sourceware.org Subject: Re: [PATCH v3 14/14] the "compile" command References: <20141101214552.13230.45564.stgit@host1.jankratochvil.net> <20141101214733.13230.49968.stgit@host1.jankratochvil.net> In-Reply-To: <20141101214733.13230.49968.stgit@host1.jankratochvil.net> Content-Type: text/plain; charset=windows-1252 Content-Transfer-Encoding: 7bit X-SW-Source: 2014-11/txt/msg00189.txt.bz2 Hi Jan, FWIW, this looks good to me, and I'm looking forward to have this pushed in. Just a few comments below. > +/* See compile-internal.h. */ > + > +void > +gcc_convert_symbol (void *datum, > + struct gcc_c_context *gcc_context, > + enum gcc_c_oracle_request request, > + const char *identifier) ... > + > + /* We can't allow exceptions to escape out of this callback. Safest > + is to simply emit a gcc error. */ > + TRY_CATCH (e, RETURN_MASK_ERROR) > + { > + struct symbol *sym; Shouldn't this catch ctrl-c too then? Likewise the other hooks. > + for (i = 0; i < 4; ++i) It'd be good to give this magic constant a name, or at a least a comment. > + { > + const char *mode = c_get_mode_for_size (1 << i); > + > + gdb_assert (mode != NULL); > + fprintf_unfiltered (buf, > + "typedef int" > + " __attribute__ ((__mode__(__%s__)))" > + " __gdb_int_%s;\n", > + mode, mode); > + } > + > +/* A cleanup function to remove a directory and all its contents. */ > + > +static void > +do_rmdir (void *arg) > +{ > + char *zap = concat ("rm -rf ", arg, (char *) NULL); > + > + system (zap); > +} This is quite scary... Could we please add an assert here that tempdir_name starts with "/tmp/gdbobj-", just in case something goes really wrong here? > + > +/* Return the name of the temporary directory to use for .o files, and > + arrange for the directory to be removed at shutdown. */ > + > +static const char * > +get_compile_file_tempdir (void) > +{ > + static char *tempdir_name; > + > +#define TEMPLATE "/tmp/gdbobj-XXXXXX" > + char tname[sizeof (TEMPLATE)]; > + > + if (tempdir_name != NULL) > + return tempdir_name; > + > + strcpy (tname, TEMPLATE); > +#undef TEMPLATE > + tempdir_name = mkdtemp (tname); > + if (tempdir_name == NULL) > + perror_with_name (_("Could not make temporary directory")); > + > + tempdir_name = xstrdup (tempdir_name); > + make_final_cleanup (do_rmdir, tempdir_name); > + return tempdir_name; > +} > + /* Override flags possibly coming from DW_AT_producer. */ > + compile_args = xstrdup ("-O0 -gdwarf-4" > + /* We use -fPIC to ensure that we can reference properly. Otherwise > + on x86-64 a string constant's address might be truncated when gdb > + loads the object; another approach would be -mcmodel=large, but > + -fPIC seems more portable across back ends. */ This comment ends up being a bit unexpected/odd, given that ... > + " -fPIC" > + /* We don't want warnings. */ > + " -w" ... patch #6 has: > +char * > +default_gcc_target_options (struct gdbarch *gdbarch) > +{ > + return xstrprintf ("-m%d%s", gdbarch_ptr_bit (gdbarch), > + gdbarch_ptr_bit (gdbarch) == 64 ? " -mcmodel=large" : ""); > +} > + IOW, is the comment stale? Thanks, Pedro Alves