On 11/13/23 18:08, Tom Tromey wrote: >>>>>> "Tom" == Tom de Vries writes: > > Tom> +/* A TUI window that doesn't scroll. */ > Tom> + > Tom> +struct tui_noscroll_window : public virtual tui_win_info { > > The "{" should be on the next line. > Done. > Tom> +/* A TUI window that occupies a single line. */ > Tom> + > Tom> +struct tui_oneline_window : public virtual tui_win_info { > > Some of these only have a single use. That seems like overkill to me, > unless we're introducing another use someday. > I understand that position, but I prefer this, even if there's one use (so, I've left it as is for now, if you object I'll drop the single use ones). In particular, I like how much shorter some window declaration are, it makes them easier to read imo. I think this style moves the boiler plate code out of the way and makes the window declaration more focused on the specifics of what it's trying to achieve. > Tom> +#define TUI_SRC_WIN \ > Tom> + (dynamic_cast (tui_win_list[SRC_WIN])) > Tom> +#define TUI_DISASM_WIN \ > Tom> + (dynamic_cast (tui_win_list[DISASSEM_WIN])) > > I think these should use gdb::checked_static_cast. Done. Thanks, - Tom