From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from smtp.polymtl.ca (smtp.polymtl.ca [132.207.4.11]) by sourceware.org (Postfix) with ESMTPS id 4567F3861865 for ; Wed, 28 Jul 2021 20:59:54 +0000 (GMT) DMARC-Filter: OpenDMARC Filter v1.4.1 sourceware.org 4567F3861865 Received: from simark.ca (simark.ca [158.69.221.121]) (authenticated bits=0) by smtp.polymtl.ca (8.14.7/8.14.7) with ESMTP id 16SKxmri026855 (version=TLSv1/SSLv3 cipher=ECDHE-RSA-AES256-GCM-SHA384 bits=256 verify=NOT); Wed, 28 Jul 2021 16:59:53 -0400 DKIM-Filter: OpenDKIM Filter v2.11.0 smtp.polymtl.ca 16SKxmri026855 Received: from [10.0.0.11] (192-222-157-6.qc.cable.ebox.net [192.222.157.6]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by simark.ca (Postfix) with ESMTPSA id 82C2A1E813; Wed, 28 Jul 2021 16:59:48 -0400 (EDT) Subject: Re: [PATCH 15/16] gdb: make cmd_list_element var an optional union To: Tom Tromey , Simon Marchi via Gdb-patches References: <20210714045520.1623120-1-simon.marchi@polymtl.ca> <20210714045520.1623120-16-simon.marchi@polymtl.ca> <87wnpacjaf.fsf@tromey.com> From: Simon Marchi Message-ID: Date: Wed, 28 Jul 2021 16:59:47 -0400 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.12.0 MIME-Version: 1.0 In-Reply-To: <87wnpacjaf.fsf@tromey.com> Content-Type: text/plain; charset=utf-8 Content-Language: en-US Content-Transfer-Encoding: 7bit X-Poly-FromMTA: (simark.ca [158.69.221.121]) at Wed, 28 Jul 2021 20:59:48 +0000 X-Spam-Status: No, score=-4.2 required=5.0 tests=BAYES_00, DKIM_SIGNED, DKIM_VALID, DKIM_VALID_AU, DKIM_VALID_EF, NICE_REPLY_A, RCVD_IN_MSPIKE_H3, RCVD_IN_MSPIKE_WL, SPF_HELO_PASS, SPF_PASS, TXREP autolearn=ham autolearn_force=no version=3.4.4 X-Spam-Checker-Version: SpamAssassin 3.4.4 (2020-01-24) on server2.sourceware.org X-BeenThere: gdb-patches@sourceware.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: Gdb-patches mailing list List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Wed, 28 Jul 2021 20:59:55 -0000 On 2021-07-28 3:47 p.m., Tom Tromey wrote: >>>>>> "Simon" == Simon Marchi via Gdb-patches writes: > > Simon> I propose changing cmd_list_element to be a union of all the possible > Simon> pointer types. Fundamentally, this doesn't change much what is > Simon> happening. But I think this helps understand better how the field is > Simon> used and get a bit of type safety (while it is still possible to use the > Simon> wrong member at some point, we can't cast to something completely > Simon> unrealted). > > Makes sense to me. > > Simon> I wrapped the union in an optional, because we need to check in some > Simon> spots whether var is set or not. I think that conceptually, an optional > Simon> makes the most sense. Another option would be to pick an arbitrary > Simon> member of the union and compare it to nullptr, whenever we want to know > Simon> whether var is set, but that seems a bit more hack-ish. > > There could be a "void *null_if_not_set" member that's only used for the > check. This would save some space. Not sure it matters though. In this case, I don't think we need to squeeze things to save every byte possible, so I would favor readability / expressiveness of the types. I also like optional, because have the possibility to add runtime checks (like _GLIBCXX_DEBUG does) to make sure we don't dereference an optional that doesn't contain a value. I'd like to add that to our gdb::optional version (maybe predicated on _GLIBCXX_DEBUG would be fine)? But I wonder why the one from libstdc++ doesn't already have it... Simon