public inbox for
help / color / mirror / Atom feed
* insight/301: Insight toolbar buttons disabled
@ 2006-07-12 12:33 dave.bryan
  0 siblings, 0 replies; 2+ messages in thread
From: dave.bryan @ 2006-07-12 12:33 UTC (permalink / raw)
  To: insight-gnats

>Number:         301
>Category:       insight
>Synopsis:       Insight toolbar buttons disabled
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    unassigned
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jul 12 12:33:02 GMT 2006
>Originator:     Dave Bryan
>Release:        v6.5.0
Cygwin, Windows XP SP2. Remote localhost ARM target using OpenOCD
I launch Insight using: insight --command=<my_cmdfile> 
<my_cmdfile> contains:
target remote localhost:3333
symbol-file <my_elf_symbol_file>
tbreak main

If any Insight view windows (registers, console, etc) other than the main debugger window were left open from the last session, they get reopened but all the toolbar buttons in the main window are greyed out (as are the Control menu options). 
Procedure in 'Description' works every time
The workaround is to close all open Insight view windows before closing the main debugger window then re-launch Insight and everything is ok. However the debugging setup is lost i.e. Insight windows have to be reopened & repositioned

^ permalink raw reply	[flat|nested] 2+ messages in thread
* Re: insight/301: Insight toolbar buttons disabled
@ 2006-11-30 23:05 kseitz
  0 siblings, 0 replies; 2+ messages in thread
From: kseitz @ 2006-11-30 23:05 UTC (permalink / raw)
  To: dave.bryan, insight-prs, kseitz, nobody

Synopsis: Insight toolbar buttons disabled

Responsible-Changed-From-To: unassigned->kseitz
Responsible-Changed-By: kseitz
Responsible-Changed-When: Thu Nov 30 23:05:10 2006
State-Changed-From-To: open->analyzed
State-Changed-By: kseitz
State-Changed-When: Thu Nov 30 23:05:10 2006
    I don't recommend doing what you are doing in your gdb script file. There is simply no need: Insight will do that for you. [Nit: You really should not use symbol-file alone. All that does is read symbol information. You get no msymbols that way... Use the "file" command so that you get both code and symbols loaded.]
    Go to File->Target Settings and fill in the all the boxes. Simply press run and insight will do everything listed in your script file. When you exit, insight will save all those settings, so that when you restart, you simply have to press run again. [Of course, if you use this on multiple different executables, you'll have to do this once for each...]
    Other problem might be that you're using tracing. Is Insight set to tracing mode? [I don't even know if that works any more...] That would probably help a lot. Look in Preferences->Global.
    As for the problem at hand, I believe that occurs because insight is confused about the state of the target, since the command file will run BEFORE insight is initialized. As of now, I don't know of any fix. That's not to say there might not be one, but I just don't know of any off the top of my head. I know I gave up on this a (long) while ago in frustration.
    For the time being, I'm leaving this bug open.

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2006-11-30 23:05 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2006-07-12 12:33 insight/301: Insight toolbar buttons disabled dave.bryan
2006-11-30 23:05 kseitz

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).