From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (qmail 99031 invoked by alias); 12 Mar 2018 21:11:00 -0000 Mailing-List: contact libc-alpha-help@sourceware.org; run by ezmlm Precedence: bulk List-Id: List-Subscribe: List-Archive: List-Post: List-Help: , Sender: libc-alpha-owner@sourceware.org Received: (qmail 97761 invoked by uid 89); 12 Mar 2018 21:10:59 -0000 Authentication-Results: sourceware.org; auth=none X-Virus-Found: No X-Spam-SWARE-Status: No, score=-2.0 required=5.0 tests=AWL,BAYES_00,SPF_PASS,T_RP_MATCHES_RCVD autolearn=ham version=3.3.2 spammy=H*r:2002 X-HELO: mailbackend.panix.com X-Gm-Message-State: AElRT7GxInXPqL51O/x6xcOUXctr69EgvX+VVZChzYha61piI60xYb1G gOuPj1Ig2RUe96TTM7cCZO0g69ZBXIEhgtNgVXo= X-Google-Smtp-Source: AG47ELvnOKK6sHMTfgvi5D6BqIk3v9ZVLg5wF16Q6FZ/HWhGKrItofLmrInkj3Na6Hhs66i3HWgUfHyqkHApY54hVDg= X-Received: by 10.202.215.138 with SMTP id o132mr5679851oig.181.1520889055981; Mon, 12 Mar 2018 14:10:55 -0700 (PDT) MIME-Version: 1.0 In-Reply-To: References: <20180307193205.4751-1-zackw@panix.com> <20180307193205.4751-2-zackw@panix.com> From: Zack Weinberg Date: Mon, 12 Mar 2018 21:11:00 -0000 X-Gmail-Original-Message-ID: Message-ID: Subject: Re: [PATCH 1/9] Use STRFMON_LDBL_IS_DBL instead of __ldbl_is_dbl. To: Adhemerval Zanella Cc: GNU C Library Content-Type: text/plain; charset="UTF-8" X-SW-Source: 2018-03/txt/msg00297.txt.bz2 On Mon, Mar 12, 2018 at 4:36 PM, Adhemerval Zanella wrote: >> va_start (ap, format); >> - res = __nldbl___vstrfmon (s, maxsize, format, ap); >> + ret = __vstrfmon_l_internal (s, maxsize, _NL_CURRENT_LOCALE, format, ap, >> + STRFMON_LDBL_IS_DBL); >> va_end (ap); >> - return res; >> + return ret; >> } > > I tend to frown at variable names changes such this case, it just add diff > lines without improvement in code readability. This might look pointless by itself, but as you go through the other patches you will see that many other functions in this file are using _different_ conventions for their variable names, so making the whole file be consistent is worthwhile IMHO. I thought it was better to touch each function as I was making other changes to it anyway. zw