public inbox for
help / color / mirror / Atom feed
* fontconfig warning after recent upgrade
@ 2013-01-30  9:19 Markus Hoenicka
  0 siblings, 0 replies; only message in thread
From: Markus Hoenicka @ 2013-01-30  9:19 UTC (permalink / raw)
  To: cygwin-xfree


I usually start X sessions from mintty using commands like:

startxwin /usr/bin/emacs somefile.txt

After I upgraded my Cygwin installation yesterday, the following  
message pops up in mintty while Emacs starts up and whenever Emacs  
loads additional fonts:

Fontconfig warning: ignoring C.UTF-8: not a valid language tag

This doesn't hurt but it is a bit annoying as it sometimes screws up  
things which I need to copy and paste from the terminal.

I used to have the following settings in my .bashrc in order to get  
English console messages:

export LC_ALL

If I change that to e.g. en_US.UTF-8, fontconfig no longer complains.  
Is this behaviour intended?


Markus Hoenicka
AQ score 38

Unsubscribe info:
Problem reports:

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2013-01-30  9:19 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-01-30  9:19 fontconfig warning after recent upgrade Markus Hoenicka

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).