public inbox for
 help / color / mirror / Atom feed
* Fw: A problem about freebsd tcpip on lpc2290 and dm9000ep
       [not found] <>
@ 2010-03-24 15:49 ` usecool
  0 siblings, 0 replies; only message in thread
From: usecool @ 2010-03-24 15:49 UTC (permalink / raw)
  To: ecos-discuss; +Cc: ecos-devel

Hello all!

I am using eCos V3.0 on my lpc2290 board. 
My board have 2MB nor FLASH(0x80000000), 1MB SRAM(0x81000000),
DM9000EP(0x83000000, IRQ is EINT0).
I modify the phycore229x's bsp for my board, now it works.

But , i meet a problem, when it power on, I can ping the board, TTL is 1-2ms.
A TCP server thread for echo received data, it worked well.

After several minutes,  I ping the board, it will no reply
or the TTL over 1000ms. I use wireshark catch the packets, I find
the PC send arp request,but the board no arp replay, or replay pack 
will delay above 20~30seconds, The TCP thread worked deviant also.
But same time ,the timer, TTY worked well.

can anyone help me? Thanks!

Jeff Liang

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2010-03-24 15:49 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <>
2010-03-24 15:49 ` Fw: A problem about freebsd tcpip on lpc2290 and dm9000ep usecool

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).