public inbox for
 help / color / mirror / Atom feed
Subject: [Bug 1001070] BSP for Olimex LPC-L2294-8M
Date: Tue, 09 Nov 2010 12:31:00 -0000	[thread overview]
Message-ID: <> (raw)
In-Reply-To: <>

Please do not reply to this email. Use the web interface provided at:

--- Comment #4 from Sergei Gavrikov <> 2010-11-09 12:31:22 GMT ---
(In reply to comment #3)
> I've followed your suggestion, and it looks like nothing broken. I think adding
> another option(s) for the FLASH part is overkilling, what is your opinion?
> This is the 1st time I'm playing with eCos and CDL, I wrote this with the
> copy-and-paste method, so any other remarks from experienced eCos user are
> welcome.

As you could notice I added in that CDL component example a line:

    define -file system.h CYGHWR_BOARD.

NOTE: for real world it would be better to name it as CYGHWR_OLIMEX_BOARD

That will define in system.h header either CYGHWR_BOARD_OLPCL2294_1M constant
or CYGHWR_BOARD_OLPCL2294_8M according your choice. So, your code in
hal_platform_setup.h (and in FLASH device driver as well) can look like:

#if defined(CYGHWR_BOARD_OLPCL2294_1M)
    // code for 1M variant
#elif defined(CYGHWR_BOARD_OLPCL2294_8M)
    // code for 8M variant
# error Not supported board.

what is more clear than your checks:


Agreed? So, try to use those constants to differ the parts of code.

Check it: if you build eCos with defaults, then your <pkgconf/system.h> will


if you import below and rebuild eCos

    user_value OLPCL2294_8M

then your <pkgconf/system.h> header will have yours


So, you can use checks like in example the above in any source which includes

Ah, once again, use there: 'define -file system.h CYGHWR_OLIMEX_BOARD' as
'CYGHWR_BOARD' is too generic name.

Configure bugmail:
------- You are receiving this mail because: -------
You are on the CC list for the bug.

  parent reply	other threads:[~2010-11-09 12:31 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-11-08 15:36 [Bug 1001070] New: " bugzilla-daemon
2010-11-09  9:53 ` [Bug 1001070] " bugzilla-daemon
2010-11-09 11:34 ` bugzilla-daemon
2010-11-09 11:43 ` bugzilla-daemon
2010-11-09 12:31 ` bugzilla-daemon [this message]
2010-11-22  9:02 ` bugzilla-daemon
2010-11-22  9:43 ` bugzilla-daemon
2010-11-22  9:46 ` bugzilla-daemon
2010-11-22 11:12 ` bugzilla-daemon
2010-11-22 11:33 ` bugzilla-daemon
2010-11-25 13:34 ` bugzilla-daemon
2010-11-25 13:38 ` bugzilla-daemon
2010-12-15  4:41 ` bugzilla-daemon
2010-12-15  6:43 ` bugzilla-daemon
2010-12-16 12:29 ` bugzilla-daemon
2010-12-16 12:34 ` bugzilla-daemon
2011-03-14 19:46 ` bugzilla-daemon
2011-11-08  1:15 ` bugzilla-daemon
2011-11-08  1:17 ` bugzilla-daemon
2011-11-08  1:17 ` bugzilla-daemon
2011-11-08 10:41 ` bugzilla-daemon
2011-11-08 17:08 ` bugzilla-daemon

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \ \ \ \

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).