public inbox for
help / color / mirror / Atom feed
* gnats/180: gen-index doesn't work with binary indexes
@ 2001-04-23  4:54 yngve.svendsen
  0 siblings, 0 replies; only message in thread
From: yngve.svendsen @ 2001-04-23  4:54 UTC (permalink / raw)
  To: gnats-gnats

>Number:         180
>Category:       gnats
>Synopsis:       gen-index doesn't work with binary indexes
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    unassigned
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Apr 23 04:54:01 PDT 2001
>Release:        Gnats 4 from latest CVS, Gnatsweb 3.95 with pending dtb patch

I tried migrating one of our databases to Gnats 4. Among other things, I had to regenerate the index file.

I first tried leaving the default setting of "binary-index true". gen-index generated a faulty index, with queries bombing with the error message

622 - Index file /usr/local/share/gnats/helpdesk/gnats-adm/index contains incorrect number of fields 

After setting binary-index to "false" and rerunning gen-index, things worked as they should.

In short, gen-index currently does not work with binary indexes.
See Description


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2001-04-23  4:54 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2001-04-23  4:54 gnats/180: gen-index doesn't work with binary indexes yngve.svendsen

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).