public inbox for gdb-patches@sourceware.org
 help / color / mirror / Atom feed
From: Simon Marchi <simark@simark.ca>
To: Tom Tromey <tromey@adacore.com>, gdb-patches@sourceware.org
Subject: Re: [PATCH 3/3] Don't let gdb_stdlog use pager
Date: Mon, 28 Nov 2022 14:23:59 -0500	[thread overview]
Message-ID: <9411d46c-14b5-1e12-08d7-2732b1d52750@simark.ca> (raw)
In-Reply-To: <20221117182904.1291713-4-tromey@adacore.com>


> diff --git a/gdb/cli/cli-interp.h b/gdb/cli/cli-interp.h
> index fa007d78621..978e7f291e4 100644
> --- a/gdb/cli/cli-interp.h
> +++ b/gdb/cli/cli-interp.h
> @@ -42,6 +42,7 @@ class cli_interp_base : public interp
>      ui_file *targ;
>      ui_file *targerr;
>      ui_file_up tee_to_delete;
> +    ui_file_up stderr_to_delete;
>      ui_file_up file_to_delete;
>      ui_file_up log_to_delete;

I think it would help me understand if the naming of these fields was a
bit better.  I think the to_delete suffixes are no longer relevant
since using ui_file_up, the types tell us about the ownership.  And I
think that "tee_to_delete" could be named "stdout_tee", and
"stderr_to_delete" could be named "stderr_tee".

Not terribly important, perhaps as a follow up.

Simon

  reply	other threads:[~2022-11-28 19:23 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-11-17 18:29 [PATCH 0/3] Do not let logging " Tom Tromey
2022-11-17 18:29 ` [PATCH 1/3] Remove 'saved_output' global Tom Tromey
2022-11-17 18:29 ` [PATCH 2/3] Don't let tee_file own a stream Tom Tromey
2022-11-28 19:18   ` Simon Marchi
2022-11-28 20:29     ` Tom Tromey
2022-11-17 18:29 ` [PATCH 3/3] Don't let gdb_stdlog use pager Tom Tromey
2022-11-28 19:23   ` Simon Marchi [this message]
2022-11-28 20:34     ` Tom Tromey

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=9411d46c-14b5-1e12-08d7-2732b1d52750@simark.ca \
    --to=simark@simark.ca \
    --cc=gdb-patches@sourceware.org \
    --cc=tromey@adacore.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).